aspose file tools*
The moose likes Web Services and the fly likes WS-Security, <wsse:Security> Missing in client request Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login
JavaRanch » Java Forums » Java » Web Services
Bookmark "WS-Security, <wsse:Security> Missing in client request" Watch "WS-Security, <wsse:Security> Missing in client request" New topic
Author

WS-Security, <wsse:Security> Missing in client request

Ravi Choudhari
Greenhorn

Joined: Aug 03, 2010
Posts: 9
Hi,

I am trying to implement a secure webservice using WS-Security in JBoss 5.1 following the steps in http://www.developer.com/java/other/article.php/3802631/Securing-Web-Services-in-JBoss-Application-Server-with-WS-Security.htm,

On the server Side I have:

Service:




standard-jaxws-endpoint-config.xml



jboss-wsse-server.xml



I hv copied jboss-wsse-server.xml, standard-jaxws-endpoint-config.xml, server.keystore, server.truststore to META-INF directory of the server project.


And on the client side I have:

standard-jaxws-client-config.xml



jboss-wsse-client.xml



Client Application:



I have copied standard-jaxws-client-config.xml, jboss-wsse-client.xml and client.keystore, client.truststore to META-INF directory of the client.

But, When there is request from the client, I am getting the following Execption.

Exception in thread "main" javax.xml.ws.soap.SOAPFaultException: This service requires <wsse:Security>, which is missing.

I have checked the request SOAP message & response messages, The client is not adding any <wsse:Security>, which is expected by the server.

 
wood burning stoves
 
subject: WS-Security, <wsse:Security> Missing in client request