This week's giveaway is in the EJB and other Java EE Technologies forum.
We're giving away four copies of EJB 3 in Action and have Debu Panda, Reza Rahman, Ryan Cuprak, and Michael Remijan on-line!
See this thread for details.
The moose likes Applets and the fly likes New class not loading Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login


Win a copy of EJB 3 in Action this week in the EJB and other Java EE Technologies forum!
JavaRanch » Java Forums » Java » Applets
Bookmark "New class not loading" Watch "New class not loading" New topic
Author

New class not loading

Rob Hunter
Ranch Hand

Joined: Apr 09, 2002
Posts: 805
I created an an applet class in my cgi-bin directory to just try out. Not too much to it, just a few text prints and such. I made some changes to the app and recompiled without error but when I try refreshing the page with the applet embedded it still shows the old code. Where is it trying to access the code for the applet? I tried clearing the cache to see if it was cached but with no success. The page that is entered in the browser is located in cgi-bin as well, I set the class attribute in the applet tag to just classname.class (no other path info preceding it). I tried running appletviewer and the applet does load and display like I want as well, just not reflected in the html page. Any help would be appreciated. Thanks.
Lester Burnham
Rancher

Joined: Oct 14, 2008
Posts: 1337
Try re-loading with the alt/options key down, and if that doesn't work- quitting the browser.
Rob Hunter
Ranch Hand

Joined: Apr 09, 2002
Posts: 805
Tried all of that and nothing has worked. I tried deleting the actual .class file and reloading the page and the darn thing still shows up in old format.
 
I agree. Here's the link: http://aspose.com/file-tools
 
subject: New class not loading
 
Similar Threads
IIS and .exe problem
Authentication Prompt
What Is the Best Way to Learn JSF Quickly?
JApplet - works on windows not on Linux
Applets on Linux