wood burning stoves 2.0*
The moose likes Struts and the fly likes Struts 1.0.2 error with JDK 1.4.2 Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login


Win a copy of Murach's Java Servlets and JSP this week in the Servlets forum!
JavaRanch » Java Forums » Frameworks » Struts
Bookmark "Struts 1.0.2 error with JDK 1.4.2" Watch "Struts 1.0.2 error with JDK 1.4.2" New topic
Author

Struts 1.0.2 error with JDK 1.4.2

Faisal Khan
Ranch Hand

Joined: Jun 29, 2003
Posts: 285
Hi,

I am not precisely clear on the error we are getting but here is what happens.

I am working on code base that we normally compile using JDK 131, we are using Struts 1.0.2 on weblogic 6.1. We deploy an ear file containing the war file, additionally we configure the application as an exploded app - both of these deploy and work fine when compiled with jdk 131.

However, I changed my JAVA_HOME to 1.4.2_08, compiled the code (this is fine), I deploy the exploded app, this too is fine apart from a few RTEs which is fine and I know how to fix. The problem is that as soon as I deploy the ear file and attempt to target my war file it throws an exception:



Now the Class not found seems not to be the actual error, I believe, the problems seems to be something different. If I unzip the war into say c:\temp and configure that as an app, that too seems to work fine.

Strange thing is the code compiles with 1.4.2_08 and deploys to WL6.1 and 8.1 as an exploded app but as soon as we try to deply the war file then we have problems.

Any help or pointers would be appreciated.

Thanks

FK


The secret to creativity is knowing how to hide your sources.
Faisal Khan
Ranch Hand

Joined: Jun 29, 2003
Posts: 285
Another thing, the few lines before the error may help as it seems to be trying to load a mapping for ServletTestRunner

 
 
subject: Struts 1.0.2 error with JDK 1.4.2
 
Similar Threads
Struts Example Help.
struts and weblogic 6.1
Weblogic 7 Connection Pool Creation
Unable to deploy an EJB.
Error while creating a new connection pool in weblogic.Kindly help me out.