File APIs for Java Developers
Manipulate DOC, XLS, PPT, PDF and many others from your application.
http://aspose.com/file-tools
Win a copy of Clojure in Action this week in the Clojure forum!
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic

Struts 1.0.2 error with JDK 1.4.2

 
Faisal Khan
Ranch Hand
Posts: 285
  • 0
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi,

I am not precisely clear on the error we are getting but here is what happens.

I am working on code base that we normally compile using JDK 131, we are using Struts 1.0.2 on weblogic 6.1. We deploy an ear file containing the war file, additionally we configure the application as an exploded app - both of these deploy and work fine when compiled with jdk 131.

However, I changed my JAVA_HOME to 1.4.2_08, compiled the code (this is fine), I deploy the exploded app, this too is fine apart from a few RTEs which is fine and I know how to fix. The problem is that as soon as I deploy the ear file and attempt to target my war file it throws an exception:



Now the Class not found seems not to be the actual error, I believe, the problems seems to be something different. If I unzip the war into say c:\temp and configure that as an app, that too seems to work fine.

Strange thing is the code compiles with 1.4.2_08 and deploys to WL6.1 and 8.1 as an exploded app but as soon as we try to deply the war file then we have problems.

Any help or pointers would be appreciated.

Thanks

FK
 
Faisal Khan
Ranch Hand
Posts: 285
  • 0
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Another thing, the few lines before the error may help as it seems to be trying to load a mapping for ServletTestRunner

 
Consider Paul's rocket mass heater.
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic