aspose file tools*
The moose likes JBoss/WildFly and the fly likes Deploy Struts2 blank application on JBoss 5 Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login
JavaRanch » Java Forums » Products » JBoss/WildFly
Bookmark "Deploy Struts2 blank application on JBoss 5" Watch "Deploy Struts2 blank application on JBoss 5" New topic
Author

Deploy Struts2 blank application on JBoss 5

Anup Om
Ranch Hand

Joined: Dec 30, 2009
Posts: 62
Hello everybody,

I am trying to deploy struts 2.2.1 blank war onto JBOSS, but getting following errors. The application deploys and runs fine on Tomcat6.
Please help me figure out where I am going wrong. Thanks for your help in advance.


SCJP6
uttam kumar
Ranch Hand

Joined: Jan 27, 2009
Posts: 128

Caused by: java.lang.NoClassDefFoundError: freemarker/template/TemplateException


Have you added required jars for your application into the lib directory?
Anup Om
Ranch Hand

Joined: Dec 30, 2009
Posts: 62
Hello Uttam,

Thanks for the reply. I was all the way looking in eclipse and was able to see freemarker jar in the lib folder of the web app in eclispe. When I deploy the application (through 'Add and Remove' server resources), the freemarker jar and javaassit jar are disappearing. I don't understand.

If I copy and paste the war file in deploy folder, the application deploys and runs fine.

Where am I going wrong in deploying the app? Is there are better approach to deploy applications?

uttam kumar
Ranch Hand

Joined: Jan 27, 2009
Posts: 128

May be some problem with your eclipse setting. Double check your eclipse configuration.
 
Consider Paul's rocket mass heater.
 
subject: Deploy Struts2 blank application on JBoss 5