File APIs for Java Developers
Manipulate DOC, XLS, PPT, PDF and many others from your application.
http://aspose.com/file-tools
The moose likes Testing and the fly likes NoSuchTableException when (trying) to use DBUnit Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login


Win a copy of The Java EE 7 Tutorial Volume 1 or Volume 2 this week in the Java EE forum
or jQuery UI in Action in the JavaScript forum!
JavaRanch » Java Forums » Engineering » Testing
Bookmark "NoSuchTableException when (trying) to use DBUnit" Watch "NoSuchTableException when (trying) to use DBUnit" New topic
Author

NoSuchTableException when (trying) to use DBUnit

William Fernandes
Greenhorn

Joined: Jul 21, 2008
Posts: 16
Hello,

I'm trying to use DBUnit (version 2.4.8) because I like the idea but the framework is detestable.

I'm following the Getting Started session of the official website, doing the most simple basic test, but it's not working when I try to run the test:


My dataset.xml (which it loads - located in the classpath, above src folder):


The error stack I get when I run my test:


Yes, the table users does exist in my local MySQL. I tried to debug and I saw that the Map which it loads with the table names comes empty, so it considers that the current schema is empty, which is not.

What am I doing wrong?

Thanks


SCJP 6
"A peaceful man stands tall" — "I tremble for my country when I reflect that God is just."
 
I agree. Here's the link: http://aspose.com/file-tools
 
subject: NoSuchTableException when (trying) to use DBUnit