aspose file tools*
The moose likes Struts and the fly likes m2eclipse + strust2 == not work Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login
JavaRanch » Java Forums » Frameworks » Struts
Bookmark "m2eclipse + strust2 == not work" Watch "m2eclipse + strust2 == not work" New topic
Author

m2eclipse + strust2 == not work

Stev Chen
Greenhorn

Joined: Dec 22, 2010
Posts: 2
hallo,

I m using m2eclipse. after i add Struts2 dependencies it not work. it strange because in jsp it recognise struts2 taglib but it not compile.

http://le-esp.fr/Video/J2EE/mavenTomcatStruts2.wmv

Thanks in advance,
Stev
Ankit Garg
Sheriff

Joined: Aug 03, 2008
Posts: 9302
    
  17

Stev Chen wrote:after i add Struts2 dependencies it not work.

Stev please go through this page once then please explain your problem in detail (my office firewall blocked the video but I'm guessing its just a tutorial video)...


SCJP 6 | SCWCD 5 | Javaranch SCJP FAQ | SCWCD Links
Fred Register
Greenhorn

Joined: Jan 04, 2011
Posts: 1
First of all, make sure you have m2eclipse-wtp installed (http://m2eclipse.sonatype.org/sites/m2e-extras)

You need to select war packaging, when setting the maven configuration (or If your project is already created, change the packaging to war).
Eclipse WTP doesn't use the same defaults as Maven (or m2eclipse for that matter). You should configure warSourceDirectory in the maven-war-plugin, so it points to WebContent (http://maven.apache.org/plugins/maven-war-plugin/war-mojo.html)

In any case you will need to right-click on your project, Maven > Update Project configuration.
 
I agree. Here's the link: http://aspose.com/file-tools
 
subject: m2eclipse + strust2 == not work