aspose file tools*
The moose likes Tomcat and the fly likes Unable to access my application in Tomcat 6 Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login
JavaRanch » Java Forums » Products » Tomcat
Bookmark "Unable to access my application in Tomcat 6" Watch "Unable to access my application in Tomcat 6" New topic
Author

Unable to access my application in Tomcat 6

Rajiv Shr
Ranch Hand

Joined: Aug 11, 2010
Posts: 37
Hi guys

I have deployed a web application in my tomcat server, and I see that the application is up and running as I am able to make SOAP requests to my application api endpoints and get a proper SOAP response. However, I am unable to access any pages under the application folder.

When I type this in the URL - http://<hostname>:<port>/myapplication/index.html or http://<hostname>:<port>/myapplication/mypage.jsp , I am not able to access it. It gives me a 404 error saying that - The requested resource () is not available.

I can see that the WAR file has exploded under the webapps with all the required files in it, and my application is running as well. But I also want to access the mypage.jsp under my application folder to bring up my app admin console, which I am not able to do at the moment.

Any ideas?
Vijitha Kumara
Bartender

Joined: Mar 24, 2008
Posts: 3825

Is this a local server? Have you tried by IP address instead host name? And are you able to access the Tomcat root (i.e.: http://<host>:<port>/)?


SCJP 5 | SCWCD 5
[How to ask questions] [Twitter]
Mitesh Soni
Greenhorn

Joined: Aug 17, 2007
Posts: 18
Please give Directory structure of your application.
Rajiv Shr
Ranch Hand

Joined: Aug 11, 2010
Posts: 37
I resolved the issue guys. Basically, we have a Tomcat home instance deployed on our linux box and multiple base instances. For some reason, tomcat was not reading the web.xml from the conf folder of the home installation. I had to copy the web.xml from the {catalina.home}/conf folder to the {catalina.base}/conf folder. The web.xml has the mappings for the default servlet/jsps. Once I restarted the server after that, things worked fine.
 
I agree. Here's the link: http://aspose.com/file-tools
 
subject: Unable to access my application in Tomcat 6