• Post Reply
  • Bookmark Topic Watch Topic
  • New Topic

JBOSS 6 Deploy Failed

 
Dominik Müller
Ranch Hand
Posts: 36
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi All,

i have a little test application (EAR Module, with one EJB and one WEB Module), is deploying fine on Glassfish v.3.
Now i tried to get the app running on JBoss 6 (jboss-6.0.0.Final) too, but getting always a dependcy error and i am running out of ideas to solve it:



Home somebody can help, thanks for any idea
Dom
 
Jaikiran Pai
Marshal
Pie
Posts: 10447
227
IntelliJ IDE Ubuntu
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Can you give a bit more details on your application packaging and what kind of beans are packaged in those? Also what does the MessageService bean look like and where is it packaged?
 
Dominik Müller
Ranch Hand
Posts: 36
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi there,

so in more detail this time. I rebuild the whole project with maven. The actual version runs again without any problems in glassfish v3, but making trouble in JBOS 6.final.
Here the project details:

Packaging: One EAR, with an JAR (EJB) and WAR


Application consits of 2 simple JSF pages, one Entity and one stateless EJB

the EJB looks like this:


because i found many many posts about simliar error messages, which were forces by invalid jpa/datasource configuration, here my one:

persistence.xml


data-source (admin-console let me ping the datasource and return data-ok-status)


and here again my error:


thanks a lot to read the mass of coding and hope you can help.
Dom
 
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic