Two Laptop Bag
The moose likes IDEs, Version Control and other tools and the fly likes Class not found test.TestIndexBean error in Eclipse Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login


Win a copy of Building Microservices this week in the Design forum!
JavaRanch » Java Forums » Engineering » IDEs, Version Control and other tools
Bookmark "Class not found test.TestIndexBean error in Eclipse" Watch "Class not found test.TestIndexBean error in Eclipse" New topic
Author

Class not found test.TestIndexBean error in Eclipse

albert kao
Ranch Hand

Joined: Feb 04, 2010
Posts: 252
Running my junit 3 test program in Eclipse has the "Class not found test.TestIndexBean" error even though I added the directory proj\build\classes (which has the TestIndexBean.class) to the Run/Debug settings/Classpath/User Entries menu in Eclipse.

java.lang.ClassNotFoundException: test.TestIndexBean
at java.net.URLClassLoader$1.run(URLClassLoader.java:200)
at java.security.AccessController.doPrivileged(Native Method)
at java.net.URLClassLoader.findClass(URLClassLoader.java:188)
at java.lang.ClassLoader.loadClass(ClassLoader.java:306)
at sun.misc.Launcher$AppClassLoader.loadClass(Launcher.java:276)
at java.lang.ClassLoader.loadClass(ClassLoader.java:251)
at org.eclipse.jdt.internal.junit.runner.RemoteTestRunner.loadClass(RemoteTestRunner.java:683)
at org.eclipse.jdt.internal.junit.runner.RemoteTestRunner.loadClasses(RemoteTestRunner.java:425)
at org.eclipse.jdt.internal.junit.runner.RemoteTestRunner.runTests(RemoteTestRunner.java:445)
at org.eclipse.jdt.internal.junit.runner.RemoteTestRunner.runTests(RemoteTestRunner.java:673)
at org.eclipse.jdt.internal.junit.runner.RemoteTestRunner.run(RemoteTestRunner.java:386)
at org.eclipse.jdt.internal.junit.runner.RemoteTestRunner.main(RemoteTestRunner.java:196)

 
I’ve looked at a lot of different solutions, and in my humble opinion Aspose is the way to go. Here’s the link: http://aspose.com
 
subject: Class not found test.TestIndexBean error in Eclipse
 
It's not a secret anymore!