This week's book giveaway is in the Design forum.
We're giving away four copies of Design for the Mind and have Victor S. Yocco on-line!
See this thread for details.
Win a copy of Design for the Mind this week in the Design forum!
    Bookmark Topic Watch Topic
  • New Topic

Lag in IE, not in Firefox

 
Amanda Albert
Ranch Hand
Posts: 41
Eclipse IDE
  • Mark post as helpful
  • send pies
  • Report post to moderator
So I have my applet running, and I had several people access the web page all at once. Some people experienced a lag in Internet Explorer, but never in Firefox. The IE lag was inconsistent; some people experienced it, others did not. The basic gist of the applet is this: the user clicks a button, moves the mouse in a blank area, after a certain number of data points are collected, the applet performed some functions, then displays the results in a JList. The lag occurs after the final data point is collected, and before the results are displayed. The lag was up to 15 seconds.

I've made some tweaks to the code, but since the lag doesn't occur in Firefox, I can't determine the issue. Here is the information I know:

IE version = 7
FF version = 3.5.5
JVM version = 1.6.17

I hope this isn't a too open-ended question. I was hoping someone would have generic thoughts on why the performance would be different between the two browsers.

I appreciate your thoughts.
 
Amanda Albert
Ranch Hand
Posts: 41
Eclipse IDE
  • Mark post as helpful
  • send pies
  • Report post to moderator
Perhaps this post might be better suited in the Performance forum? I have re-posted there, so perhaps we can close this thread.

Thanks!
 
Jelle Klap
Bartender
Posts: 1951
7
Eclipse IDE Java
  • Mark post as helpful
  • send pies
  • Report post to moderator
Our Performance forum probably is a better fit.
In the future though, please refrain from crossposting - I or another moderator would have happily moved this topic for you
I'll close this one.
 
    Bookmark Topic Watch Topic
  • New Topic