Win a copy of Re-engineering Legacy Software this week in the Refactoring forum
or Docker in Action in the Cloud/Virtualization forum!
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic

Android emulator screen looks like mario big world

 
Ben David
Ranch Hand
Posts: 67
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
I attached a picture of what the emulator looks like

I got the android SDK and emulator set up following this video.
http://www.youtube.com/watch?v=IaA7SVDEQcQ

When I try to run the emulator everything is huge on the screen. (see attached screen shot)

Any idea's what I might be doing wrong?

(This is on Windows 7 with netbeans 6.9.1, and the latest SDK downloaded today -- the emulator was running (or trying to anyway) android 2.3.1)


p.s. I first posted this on the netbeans forums, just because I was already there. Realized right after, I would have rather posted it here.
http://forums.netbeans.org/viewtopic.php?p=96519#96519
ScreenClip.png
Screen Shot
[Thumbnail for ScreenClip.png]
 
Monu Tripathi
Rancher
Posts: 1369
1
Android Eclipse IDE Java
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Ben:
A few things:
1. What is your AVD configuration in terms of screen size and density?
2. Which version of SDK are you using and what is your screen resolution?
 
Peter Johnson
author
Bartender
Posts: 5852
7
Android Eclipse IDE Ubuntu
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
I have noticed that error dialogs like this tend to be very large on the default emulator. But the text in my ListView was a nice, small 14pt font. The text in my input dialog was a tad larger though, possibly 20pt. Though the sizes tend to be close to what my HTC EVO shows.
 
Ben David
Ranch Hand
Posts: 67
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Monu Tripathi wrote:Ben:
A few things:
1. What is your AVD configuration in terms of screen size and density?
2. Which version of SDK are you using and what is your screen resolution?


Size was WVGA800 by default -- I manually set resolution to 480x800
the "Abstracted LCD density" is at 240 which was the default

I just download the SDK from http://developer.android.com/sdk/index.html yesterday. version r09 I think.



Not sure how this might relate -- but I also just tried out App Inventor yesterday. When I opened an emulator through App Inventor, things looked fine.

 
Ben David
Ranch Hand
Posts: 67
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Also -- when the emulator starts, there is a windows that flashes on for a second that says "error loading preferences"

But I just noticed this window comes up regardless of if the emulator is started via netbeans or via the SDK avd manager. And when I start it via the AVD manager, it looks fine. (well the screen looks fine -- but there is not keyboard/button tray to the side of it -- JUST the screen)

It is just when it is started via netbeans that it looks like mario big world

Oh -- and I think you asked, monu, my computer screen resolution. I have a dual monitor set up. One as 1600x900 and the other is 1280x1024


@peter: it is actually not just the error dialog. See screenshot below. Everything looks as if the resolution being emuldated is crazy low.
ScreenClip.png
[Thumbnail for ScreenClip.png]
 
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic