This week's book giveaway is in the Android forum.
We're giving away four copies of Head First Android and have Dawn & David Griffiths on-line!
See this thread for details.
The moose likes Struts and the fly likes form bean is not getting populated while using enctype= Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login


Win a copy of Head First Android this week in the Android forum!
JavaRanch » Java Forums » Frameworks » Struts
Bookmark "form bean is not getting populated while using enctype="multipart/form-data"" Watch "form bean is not getting populated while using enctype="multipart/form-data"" New topic
Author

form bean is not getting populated while using enctype="multipart/form-data"

Sam Mites
Greenhorn

Joined: Nov 27, 2005
Posts: 15
Hi;
the action form fields are not getting populated while using <html:form enctype="multipart/form-data"> whils uploading files. What may be the probable causes for the faliure.

Thanks
Merrill Higginson
Ranch Hand

Joined: Feb 15, 2005
Posts: 4864
I'd suggest taking a close look at the upload sample that comes with the struts download and comparing it to your code to look for what might be going wrong. Make sure that in your form bean, you have defined the upload file as type org.apache.struts.upload.FormFile.


Merrill
Consultant, Sima Solutions
 
I agree. Here's the link: http://aspose.com/file-tools
 
subject: form bean is not getting populated while using enctype="multipart/form-data"
 
It's not a secret anymore!