Win a copy of Think Java: How to Think Like a Computer Scientist this week in the Java in General forum!
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic

NEWBIE question on created test client in Eclipse

 
Melinda Savoy
Ranch Hand
Posts: 387
Eclipse IDE Java
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
I am VERY new to web services and consequently my questions may not be stated correctly so my apologies if so. I created a test dynamic web project called TestWS in Eclipse whereby I would like to validate against my database using my DAO code the parameters being sent in the method I'm calling.

My service bean class is as follows:



I then created a web service that created a test client called TestWSClient but when I enter values in via the TestClient.jsp page I am getting a NPE. I put a breakpoint in my service bean but my code never went to my code.

I'm not sure why I cannot get to my service bean class. Any direction/help would be greatly appreciated. Thank you.

 
Melinda Savoy
Ranch Hand
Posts: 387
Eclipse IDE Java
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Please help. Still trying to resolve my original problem but maybe describing a more specific problem with an additional question someone might be able to help.

1. When trying to RUN ON SERVER the TestClient.jsp page from the TestWSClient project I got the following error and any help/direction would be greatly appreciated as I have no idea what the problem::



2. If I make a change to the service bean, how do I update the WSDL in Eclipse so that I can re-run the webservice? Again, any help/direction would be appreciated. Thank you.
 
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic