File APIs for Java Developers
Manipulate DOC, XLS, PPT, PDF and many others from your application.
The moose likes IDEs, Version Control and other tools and the fly likes eclipse environment issue Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login

Win a copy of REST with Spring (video course) this week in the Spring forum!
JavaRanch » Java Forums » Engineering » IDEs, Version Control and other tools
Bookmark "eclipse environment issue" Watch "eclipse environment issue" New topic

eclipse environment issue

Mathew Lee
Ranch Hand

Joined: Jun 08, 2009
Posts: 238

I created one dynamic webproject (say testweb) to run a sample jsf application got error like error like need jdk1.6 etc while compiling itseld.
step1: I went to eclipse windows preferances -->general--->java--->compiler-->compiler compliance level i gave as 1.6 in the drop down.

But still it used give error like need jdk1.6 etc.

step2: When i went testweb project right clicked and properties-->java compiler-->java compilance level to 1.6 from 1.5 then it fixed the error.

My question is when i did step1 i thought it will set jdk to all projects globally but it did not unless and until I did step2 specifically for this individual project. I am bit confused. Can you please advise. any ideas, sample code, resources, highly appreciated. thanks in advance
Campbell Ritchie

Joined: Oct 13, 2005
Posts: 45277
That would sit better on our IDEs forum. Moving.
Peter Johnson

Joined: May 14, 2008
Posts: 5852

Step 1 sets the default JDK which is used for new projects - it does not update the JDK used for existing projects.

JBoss In Action
I agree. Here's the link:
subject: eclipse environment issue
It's not a secret anymore!