aspose file tools*
The moose likes Tomcat and the fly likes no connection to localhost possible Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login
JavaRanch » Java Forums » Products » Tomcat
Bookmark "no connection to localhost possible" Watch "no connection to localhost possible" New topic
Author

no connection to localhost possible

Peter Seidel
Greenhorn

Joined: Jan 21, 2011
Posts: 9
Hallo, I am lost...

I did install Tomcat 7.0.6, but cannot open its home page:
I have a 64bit Win7 and used the 32/64bit Tomcat installer.
I have a 64bit Java SDK 1.6.0_22 path in the PATH variable.
The Apache Tomcat service is running and I can't find a problem in the logs.
If I am writing http://localhost into the address bar of my browsers, I always get error messages (network problem, connection faild).

What am I doing wrong? Can somebody help me please?
Thank you in advance!
Tim Holloway
Saloon Keeper

Joined: Jun 25, 2001
Posts: 15641
    
  15

The correct URL to talk to Tomcat is "http://localhost:8080" unless you've changed Tomcat's default port settings.

You web browser will attempt to contact "http://localhost:80" if you don't explicitly provide a port number in your URL.


Customer surveys are for companies who didn't pay proper attention to begin with.
Peter Seidel
Greenhorn

Joined: Jan 21, 2011
Posts: 9
Ok, thank you a lot!

I did copy my war file to the webapps folder - it got extracted automatically.
But if I add the name of my war file after the address (like http://localhost:8080/[my_app]), I do only get a HTTP Status 404 error:
The requested resource is not available.

Can it be, that it is not good, to install Tomcat under the programs folder, since this folder is protected by the System (Win7)?

Thank you in advance,
Peter
 
I agree. Here's the link: http://aspose.com/file-tools
 
subject: no connection to localhost possible
 
Similar Threads
Connection between tomcat and apache
Tomcat application deployment problem
Where to put <Context path> in server.xml
Problem in IIS7(64bit) on Windows 2008(64bit) Configuration with JBOSS 4.3.0
I can't start tomcat service