wood burning stoves 2.0*
The moose likes Other JSE/JEE APIs and the fly likes Cannot run Apache James Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login
JavaRanch » Java Forums » Java » Other JSE/JEE APIs
Bookmark "Cannot run Apache James" Watch "Cannot run Apache James" New topic
Author

Cannot run Apache James

Alejandro Barrero
Ranch Hand

Joined: Aug 01, 2005
Posts: 309
I installed james-2.3.2, but when I run bin\run.bat I get the error:
ERROR 2011-02-05 16:18:54.896 [Phoenix.] (): There was an error running phase "startup" for Block named "pop3server". (Reason: Component named "pop3server" failed to pass through the Starting stage. (Reason: java.net.SocketException: Unrecognized Windows Sockets error: 0: JVM_Bind).).
Does this mean that I have to have a Pop3 server?
I am trying to write a program to send email from computers in small companies without their own email server. Is there anything that I can use? Some time ago I tried a program called aspirin, but that didn't work.

Your help will be greatly appreciated,
Alejandro Barrero
Ernest Friedman-Hill
author and iconoclast
Marshal

Joined: Jul 08, 2003
Posts: 24183
    
  34

James is a POP3 server, so no, you don't need another one. The error message is pretty vague, but it's saying that the POP3 part of James could not start because it couldn't open the socket it needs to listen on. Two possible reasons are (1) you already have some other POP3 server running on your machine, or some other service using that same TCP port (110); or (2) you've got something like Windows Firewall configured such that it's blocking the attempt to listen on that port.


[Jess in Action][AskingGoodQuestions]
Alejandro Barrero
Ranch Hand

Joined: Aug 01, 2005
Posts: 309
Thank you Ernest. This is my home laptop and I don't have a Pop3 server. Also I turned of the fire wall and still got the same error. Searching the internet for "Reason: java.net.SocketException: Unrecognized Windows Sockets error: 0: JVM_Bind" I got the same information that that other process is using the port. I ran "netstat -a" and I got a lot of lines but I didn't see port 110. The only conf file is wrapper.conf and it only shows wrapper.port=15012. Is there a way to set a different port?
 
I agree. Here's the link: http://aspose.com/file-tools
 
subject: Cannot run Apache James
 
Similar Threads
newbie question
problem with struts1.1 please help me...
TLS security in email
Using email to access a J2EE application
classpath problem