Meaningless Drivel is fun!*
The moose likes BEA/Weblogic and the fly likes Request Timing out in weblogic 8.1 Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login
JavaRanch » Java Forums » Products » BEA/Weblogic
Bookmark "Request Timing out in weblogic 8.1" Watch "Request Timing out in weblogic 8.1" New topic

Request Timing out in weblogic 8.1

bhanu chowdary
Ranch Hand

Joined: Mar 09, 2010
Posts: 256

The session timeout in my application is 30 mins. There are few screens in the application which will take 5-7 mins for the data to be processed and displayed on the screen. For these screens immediately after 5 mins the session is timing out.

I suspect this is something to do with the weblogic server configuration. I have checked the configuration from the screen and at only one place I found something related to 5 mins; domain>Configuration>JTA>Checkpoint Interval Seconds:300.
But I dont think this has anything to do with my session timeout problem.
Please let me know how to take care of this situation
robin patel

Joined: Jan 03, 2011
Posts: 16
Hi Bhanu,

Can you help me with your environment a bit?

Is there any Webserver in front of weblogic?

How is the request flow for your application?


robin patel

Joined: Jan 03, 2011
Posts: 16
in addition to that,

can you also test this suggestion of increasing the "Thread Count"

To modify the default execute queue thread count using the Administration Console:
Start the Administration Server if it is not already running.
Access the Administration Console for the domain.
Expand the Servers node in the left pane to display the servers configured in your domain.
Right-click the name of the server instance that contains the execute queue you want to configure, and then select View Execute Queues on the pop-up menu to display a table of execute queues that can be modified.
Note: You can only modify the default execute queue for the server or a user-defined execute queue.
In the Name column, click directly on the default execute queue name to display the Configuration tab for modifying execute queues.
Locate the Thread Count value and increase or decrease it, as appropriate.
Click Apply to save your changes.
Reboot the selected server to enable the new execute queue settings.

The value of the ThreadCount attribute depends very much on the type of work your application does. For example, if your client application is thin and does a lot of its work through remote invocation, that client application will spend more time connected — and thus will require a higher thread count — than a client application that does a lot of client-side processing.
If you do not need to use more than 15 threads (the development default) or 25 threads (the production default) for your work, do not change the value of this attribute. As a general rule, if your application makes database calls that take a long time to return, you will need more execute threads than an application that makes calls that are short and turn over very rapidly. For the latter case, using a smaller number of execute threads could improve performance.

For more information visit

Let me know if this helps

bhanu chowdary
Ranch Hand

Joined: Mar 09, 2010
Posts: 256
Hi Robin,

Find below the environment details.

Weblogic - 8.1
java - 1.4.2
struts - 1.1

In the development environment I dont have any clusters setup, only have a single server and the application is deployed on that, the 5 mins session timeout is not happening here; but in the production environment we have a clustered environment with admin and four managed servers set-up, this is where I am encountering this session time out problem.
I would check again by increasing the thread count as you suggested once I reach my workplace tomorrow. But just to highlight, we use struts framework in the application the timeout is happening after the whole Action class is complete and when it reaches the actionmapping.findForward("success"), instead of forwarding it to the appropriate jsp page it is getting trapped in the SessionFilter.

Thanks for your inputs.
I agree. Here's the link:
subject: Request Timing out in weblogic 8.1
Similar Threads
Session timeout - Apache overriding Tomcat?
Session never timesout in FF and IE7
Default Session timeout issues Configuration!!!
Auto Session logoff
Session time out only for one particular jsf Session scoped managed bean