aspose file tools*
The moose likes Ant, Maven and Other Build Tools and the fly likes errors generated when running Ant build file in Eclipse Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login
JavaRanch » Java Forums » Engineering » Ant, Maven and Other Build Tools
Bookmark "errors generated when running Ant build file in Eclipse" Watch "errors generated when running Ant build file in Eclipse" New topic
Author

errors generated when running Ant build file in Eclipse

Melinda Savoy
Ranch Hand

Joined: Jun 21, 2005
Posts: 387

I am trying to complete a tutorial on ANT. I have created a project and the project calls for creating the WAR file using ANT. I am trying to to implement this in my dynamic web project in Eclipse and all my JAR files sit on the server and NOT in the lib directory of WEB-INF. I made a reference to this in my BUILD.XML file but I'm getting errors.

Here is my BUILD.XML file which I think is pretty simplistic:



The checked (selected) targets to execute in the TARGETS tab of the Edit Configuration dialog box in Eclipse are:

init
compile
war

Here are the errors that is being generated when I right-click the build.xml file and RUN AS ANT BUILD:



Being new to ANT, I'm not sure what I'm doing wrong. Any help/direction would be appreciated.

Thanks.
Melinda Savoy
Ranch Hand

Joined: Jun 21, 2005
Posts: 387

I just got my problem resolved, I think because I was able to run a successful build with a generated WAR file.

I added the following to the compile which I had missed:



Thanks anyway.
 
 
subject: errors generated when running Ant build file in Eclipse