File APIs for Java Developers
Manipulate DOC, XLS, PPT, PDF and many others from your application.
The moose likes Web Services and the fly likes Run As -> Run on server cause Http 404 error Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login

Win a copy of REST with Spring (video course) this week in the Spring forum!
JavaRanch » Java Forums » Java » Web Services
Bookmark "Run As -> Run on server cause Http 404 error" Watch "Run As -> Run on server cause Http 404 error" New topic

Run As -> Run on server cause Http 404 error

Luke Colliton

Joined: Feb 11, 2011
Posts: 1
Currently, I am using the following Eclipse version 3.5 SR2 with both axis 2 1.4 and tomcat v6.0.30 installed.
Java jdk is jdk1.6.0_23.

Tomcat server is setup as an local host server using port 8081. To test if the localhost Tomcat was up and running
entered the following url http:// localhost:8081. The proper page was displayed.

Then based on the following tutorial ( ) using the following
section "4. Create a complex Web Service".

Was able to create an web service and I believe this was deployed properly after restarting Tomcat.
This belief was based on the following information in the console view.

[INFO] Deploying Web service: CarService - file:/X:/Eclipse_jee_galileo-SR2/eclipse/ws_workspace/.metadata/.plugins/org.eclipse.wst.server.core/tmp0/wtpwebapps/de.vogella.webservice.complex.soap.axis2/WEB-INF/services/CarService/

My next step was to create a client for the web service.

Tried to determine the url for the next step by first highlighting the project and then select run as -> run on server,
the following message is generated.

HTTP Status 404 - /de.vogella.webservice.complex.soap.axis2/
type Status report
message /de.vogella.webservice.complex.soap.axis2/
description The requested resource (/de.vogella.webservice.complex.soap.axis2/) is not available.
Apache Tomcat/6.0.30

Very new to Tomcat and web development and not sure where to look. Is there any other information that can be provided that would be helpful.

Any suggestion would be appreciated.
I agree. Here's the link:
subject: Run As -> Run on server cause Http 404 error
It's not a secret anymore!