• Post Reply
  • Bookmark Topic Watch Topic
  • New Topic

Problem in RAD 7.0 with java Swing componet

 
imran tariq
Greenhorn
Posts: 24
Eclipse IDE Firefox Browser Java
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi all,
I am working on swing components and got the following error when i tried to add swing label "add(label)". Here is the error.

Unhandled exception
Type=Segmentation error vmState=0x00040000
J9Generic_Signal_Number=00000004 ExceptionCode=c0000005 ExceptionAddress=6918465C ContextFlags=0001003f
Handler1=008505B0 Handler2=008974F0 InaccessibleAddress=AB924D78
EDI=68D11CA4 ESI=FF333333 EAX=00000000 EBX=00000006
ECX=00000009 EDX=AB924D78
EIP=6918465C ESP=698FFC70 EBP=00000A00
Module=C:\Program Files\IBM\SDP70\jdk\jre\bin\awt.dll
Module_base_address=69170000 Offset_in_DLL=0001465c
Target=2_30_20060915_08260_lHdSMR (Windows XP 5.1 build 2600 Service Pack 2)
CPU=x86 (4 logical CPUs) (0xcb53f000 RAM)
JVMDUMP006I Processing Dump Event "gpf", detail "" - Please Wait.
JVMDUMP007I JVM Requesting System Dump using 'D:\codeBase\Code\EncryptPassword\core.20110215.105747.2328.dmp'
JVMDUMP010I System Dump written to D:\codeBase\Code\EncryptPassword\core.20110215.105747.2328.dmp
JVMDUMP007I JVM Requesting Snap Dump using 'D:\codeBase\Code\EncryptPassword\Snap0001.20110215.105747.2328.trc'
JVMDUMP010I Snap Dump written to D:\codeBase\Code\EncryptPassword\Snap0001.20110215.105747.2328.trc
JVMDUMP007I JVM Requesting Java Dump using 'D:\codeBase\Code\EncryptPassword\javacore.20110215.105747.2328.txt'
JVMDUMP010I Java Dump written to D:\codeBase\Code\EncryptPassword\javacore.20110215.105747.2328.txt
JVMDUMP013I Processed Dump Event "gpf", detail "".


Same code is working fine in Eclipse and I can see my swing components working but giving above error in RAD 7.0. I also tried this code on another machine in RAD but got the same error. I am in serious hurry as I am getting late for my this task. All my other projects are working good in RAD 7.0.

Please tell me is this is a bug in RAD 7.0 or there is a miss in settings for JRE etc.

Thanks & Ragards
Imran Tariq

 
Campbell Ritchie
Sheriff
Posts: 48652
56
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Is that a compiler error?
 
imran tariq
Greenhorn
Posts: 24
Eclipse IDE Firefox Browser Java
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
No, this is not a compiler error. code is working fine in Eclipse but having problem in RAD.
 
Jesper de Jong
Java Cowboy
Saloon Keeper
Posts: 15216
36
Android IntelliJ IDE Java Scala Spring
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Looking at this line in your error message:

Module=C:\Program Files\IBM\SDP70\jdk\jre\bin\awt.dll

It looks like IBM RAD runs on its own, bundled JDK, and there's probably a bug in it, because it crashes in native code in awt.dll.
 
imran tariq
Greenhorn
Posts: 24
Eclipse IDE Firefox Browser Java
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Thanks Jesper you are right. It was the jre's problem. RAD's default JRE has a bug in it. After configuring othe JRE I got my program running.
Regards
Imran
 
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic