Win a copy of Design for the Mind this week in the Design forum!
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic

Trouble generating Exchange web service client using Axis2

 
Dave Alvarado
Ranch Hand
Posts: 436
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi,

I am trying to generate a web service client for Exchange Web services (2010). I saved my WSDL, "types.xsd" and "messages.xsd" locally. I have a simple Ant build script ...



but I get this error ...



Any ideas how to troubleshoot this further or other steps for going forward? Thanks, - Dave
 
Jesus Mireles
Ranch Hand
Posts: 122
IntelliJ IDE Java Mac
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
If I remember correctly Microsoft left out the service element from the WSDL. I remember a while back I ended up modifying the WSDL and adding that missing section and then Axis worked fine.
 
Alex Stolovski
Greenhorn
Posts: 1
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
You can also look at JWebServices for Exchange, an API that makes it easy to work with Exchange 2007/2010
 
Dave Alvarado
Ranch Hand
Posts: 436
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi,

Regarding

> I remember a while back I ended up modifying the WSDL and adding that missing section and then Axis worked fine

Can you show me how you modified the WSDL? What do you mean they left out the service element?

Alex, Thanks for the link, but it looks like you have to pay for JWebService. Do you know of any open source or other freeware that interacts with Exchange?

Thanks, - Dave
 
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic