• Post Reply
  • Bookmark Topic Watch Topic
  • New Topic

Funny error

 
basha khan
Ranch Hand
Posts: 516
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
In my struts app, in one of the pages,i dont get values in server. I mean when i enter values in Textfield, and submit the form, all the form values getting in server is NULL. The error is in INTERNET EXPLORER ONLY. in FIREFOX, It works FINE.

I am not getting any clue why this happens. IE only have problem. and it's strange, Plz share ur thoughts,

Thanks
Basha
 
Vicky Pandya
Ranch Hand
Posts: 148
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
post your jsp code.
 
Merrill Higginson
Ranch Hand
Posts: 4864
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
The first thing I'd do is check to see if javaScript is used in the page. Implementations of javaScript are significanltly different on IE and FireFox. If the javaScript was written and tested only on FireFox, it will probably require some modification in order to run on IE.

It can be made to run on both platforms, but it requires code to test which platform is being used and branching the code accordingly.
 
basha khan
Ranch Hand
Posts: 516
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Originally posted by Merrill Higginson:
The first thing I'd do is check to see if javaScript is used in the page. Implementations of javaScript are significanltly different on IE and FireFox. If the javaScript was written and tested only on FireFox, it will probably require some modification in order to run on IE.

It can be made to run on both platforms, but it requires code to test which platform is being used and branching the code accordingly.


There is NO JAVASRIPT in the page.

there is only,

<html:form action="/somection.do?meth=load" >//i use LookUpDispatchAction

---
---
</html:form>

Works in Firefox. Not in IE. No idea yet.

I tried this also,

<html:form action="/somection.do?meth=load" method="POST" >

---
---
</html:form>
[ January 15, 2006: Message edited by: basha khan ]
 
basha khan
Ranch Hand
Posts: 516
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
IE sends the form to the server. But values entered in Textfields are NULL. Firefox it's fine.
 
Merrill Higginson
Ranch Hand
Posts: 4864
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Use the "view Source" function in IE to display the html that is actually rendered to the page. Do you see the <input type="text" > tags that you would expect?

Look for missing end tags or other flaws in your HTML. Firefox may be more forgiving of those that IE.
[ January 15, 2006: Message edited by: Merrill Higginson ]
 
basha khan
Ranch Hand
Posts: 516
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
I am having this error for only ONE user role. The rest works fine. And i cant figure out what is wrong. FIREFOX it's fine..
 
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic