aspose file tools*
The moose likes Ant, Maven and Other Build Tools and the fly likes Question on Ant script error in my build.xml file in the Eclipse IDE Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login


Win a copy of Spring in Action this week in the Spring forum!
JavaRanch » Java Forums » Engineering » Ant, Maven and Other Build Tools
Bookmark "Question on Ant script error in my build.xml file in the Eclipse IDE" Watch "Question on Ant script error in my build.xml file in the Eclipse IDE" New topic
Author

Question on Ant script error in my build.xml file in the Eclipse IDE

Melinda Savoy
Ranch Hand

Joined: Jun 21, 2005
Posts: 387

Currently I am working on my local XP box in Eclipse Helios. The version of ANT that I have loaded is apache-ant-1.8.2. I am a NEWBIE in regards to ANT and need some help.

The error I am getting in the build.xml file is: Default target dist does not exist in this project

However, when I go to the Eclipse workspace where I have my project: C:\eclipse-3.6-helios-SR1\Workspace\TestWebService\RequisitionWS

And the directory structure for my project, RequisitionWS, is:

.settings
build folder
dist folder
src folder
WebContent folder
.classpath
.project
build.xml

My build.xml file is as follows:



Can someone please tell me what I'm doing wrong? ANY help/direction would be greatly appreciated.

Thanks.


J J Singh
Greenhorn

Joined: Mar 20, 2010
Posts: 12
Hi

Read the start of build.xml

<project name="RequisitionWS" default="dist" basedir=".">

it says default target is dist

But there is no target with name dist defined

there should be some target named dist similar to this

<target name="dist">

///some tasks


</target>

Hope it helps

Melinda Savoy
Ranch Hand

Joined: Jun 21, 2005
Posts: 387

Thank you for the reply. That did it.
 
I agree. Here's the link: http://aspose.com/file-tools
 
subject: Question on Ant script error in my build.xml file in the Eclipse IDE