wood burning stoves 2.0*
The moose likes Java in General and the fly likes Java Version Warning Message Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login


Win a copy of Murach's Java Servlets and JSP this week in the Servlets forum!
JavaRanch » Java Forums » Java » Java in General
Bookmark "Java Version Warning Message" Watch "Java Version Warning Message" New topic
Author

Java Version Warning Message

Surya Priyadarshini
Greenhorn

Joined: Sep 09, 2009
Posts: 10
Hi All,

I have been a very infrequent visitor to this forum, but it has always helped me find my answers. I hope I am posting my question in the right section. So here it goes..

My system is running Win XP Pro, IE8 and Java 6 update 20 as default java. I have an an application which runs only on java 1.5. Everytime I launch this application it gives me a warning that, this application runs on an earlier version of java and gives me an option to "Run" or "Cancel". If I cancel, the application wont run at all. Is there any way of supressing this warning message?

I cannot make any changes to the app itself, but I can change any settings in the explorer or the java package installed on my system.
Please help.
I appriciate the time it takes to send your responses.

Thanks.


Studying for SCJP 6
Manish Singh
Ranch Hand

Joined: Jan 26, 2007
Posts: 160
There should not be any problem in running java 5 application in java 6 as most of the product including java is backward compatible.

There are a few things you should do:
1) Try to find out what language feature will be causing problems if you run it in java 6.
2) If you should run it using java 5 only then install jre 5 on your system and update your JAVA_HOME system path to use java 5. Then run the application you will not get any warning.
Surya Priyadarshini
Greenhorn

Joined: Sep 09, 2009
Posts: 10
Thanks Mayank.
I tried that way but it didn't work.
Here is my situation,

a. My application needs 1.5_06 and my default is 1.6_20.
b. Application launches with warnings, if I check the "Enable next generation java plugin" in the java control panel but I am not able to supress the warning.
c. If I uncheck the "Enable next generation java plugin" option, my application is giving fatal exception ( I suppose it tries to use the latest java on the workstation which is 1.6 and fails)

Is there any way to install the the plugin for java 5 application separately? so that my app doesnt fail and doesnt give any warning?

Ulf Dittmer
Marshal

Joined: Mar 22, 2005
Posts: 41079
    
  43
a. My application needs 1.5_06 and my default is 1.6_20.

By "my application", do you mean you control the source code? If so, why does it need Java 5 and can't run on Java 6? That's a very unusual situation that you should rectify if at all possible.


Ping & DNS - my free Android networking tools app
Surya Priyadarshini
Greenhorn

Joined: Sep 09, 2009
Posts: 10
Sorry if it sounded like that, but I do not control the source of this application. It is a critical application that is installed on my work machine.
Ulf Dittmer
Marshal

Joined: Mar 22, 2005
Posts: 41079
    
  43
What does the customer support of the vendor of that software say about this?
Surya Priyadarshini
Greenhorn

Joined: Sep 09, 2009
Posts: 10
It is an in-house app. The development team says it works with java 5 only. So if I uninstall ver 6, it works like a charm but I am in no position to do that as there are other critical apps in the environment which use java 6 update 20 as default.
prem pillai
Ranch Hand

Joined: Nov 02, 2007
Posts: 87

You need not uninstall java 1.6 . You can run multiple java runtimes on the same machine. Seek the help of your internal IT support guys to get the 1.5 runtime installed.

What is the nature of this application? and how are you starting it up (from a commad line Or brower ?)
Ulf Dittmer
Marshal

Joined: Mar 22, 2005
Posts: 41079
    
  43
Tell the dev team that they should make their app compatible with Java 6. Java itself is backwards-compatible, and there's no good reason why the app shouldn't be, too.
Surya Priyadarshini
Greenhorn

Joined: Sep 09, 2009
Posts: 10
Thanks, Prem. My app is browser based. It launches an applet.
I have both on 1.5 and 1.6 installed on my workstation but the 1.6 java package forces the use of latest Java Plugin which is resulting in the warning.

Apperently the solution is a registry fix that allows the use of same version plugin as JRE, so no more warning pop-ups. The "Next generation plugin" does not need to be checked.
I will test this solution and update everybody with the results. Thank you all for your contribution.
 
I agree. Here's the link: http://aspose.com/file-tools
 
subject: Java Version Warning Message
 
Similar Threads
TimerTask.cancel() not killing tasks in the webcontainer
wireless toolkit 2.0
hprof/prof Confusion
securing a web application in wsad
struts 2 in eclipse