• Post Reply
  • Bookmark Topic Watch Topic
  • New Topic

Tomcat 5.5 exe installation on Windows7 problem

 
Priety Sharma
Ranch Hand
Posts: 156
Android Eclipse IDE
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
I used the tomcat 5.5 exe to install tomcat 5.5 on my windows7 machine.

It installs properly. I even deployed a struts application war file and it works.

The problem is when I click the windows button on my laptop and click the Monitor tomcat I get an error message.
It says "Access is denied. Unable to open service Tomcat 5"

I have attached the images leading to the error.

When I check in the services Tomcat is started.
But I dont get the monitor tomcat option to start and stop tomcat the usual way.
Is this something to do with permissions on Windows7 ?


I have installed at "C:\Apache Software Foundation\Tomcat5.5".
Tomcat 5 - Windows7 error.png
[Thumbnail for Tomcat 5 - Windows7 error.png]
The error received for tomcat.
Monitor Tomcat.png
[Thumbnail for Monitor Tomcat.png]
Monitor Tomcat option in window menu
 
Rahul Sudip Bose
Ranch Hand
Posts: 637
Eclipse IDE Firefox Browser Java
  • Likes 1
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
I have win 7 - 64 bit, tomcat 5.5 (and 7 also) :
After much frustration, i tried this fluke and it worked for me :

1.Right-click on "monitor tomcat" button.
2.click on properties.
3.go to compatibility tab.
4.at bottom, tick the check-box "Run this program as an administrator"...click ok.

Tomcat appears in taskbar.

I hope this helps....

regards.
 
Priety Sharma
Ranch Hand
Posts: 156
Android Eclipse IDE
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi Rahul,

Thanks man.
What you said works.
I hope the problem is solved for good and does not happen again on machine restart.
Thanks again!
 
M Meah
Greenhorn
Posts: 1
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Rahul Sudip Bose wrote:I have win 7 - 64 bit, tomcat 5.5 (and 7 also) :
4.at bottom, tick the check-box "Run this program as an administrator"...click ok.

...

I hope this helps....



Yep. That worked. Thanks!
 
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic