Win a copy of Learn Spring Security (video course) this week in the Spring forum!
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic

Expression Language error

 
Mikel Gonzalez
Greenhorn
Posts: 4
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi there, I've tried to configure the EL with JSF on eclipse and Tomcat6 and I get the following error:

The ELResolvers for JSF were not registered with the JSP container.

There are no JSF pages in mi app, since I'm working with facelets. I'd be pleased If anyone could help me.

Thanks
 
Tim Holloway
Saloon Keeper
Pie
Posts: 17989
47
Android Eclipse IDE Linux
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Welcome to the JavaRanch, Mikel!

I'm a little confused because you appear to be saying that you're using JSF at the same time you say you're not using JSF.

Depending on which webapp container you're using and which version of that webapp container you're deploying to, you may or may not have to include some support jars in your WAR. For example, EL is integrated into Tomcat 6, but has to be supplied as part of the webapp in Tomcat 5.5. Likewise, the jsf-impl libraries are sometimes supplied by the container and sometimes have to be manually provided as part of the WAR.
 
Mikel Gonzalez
Greenhorn
Posts: 4
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Sorry, you are right, I tried to say that I'm not using JSP pages...

I'm using tomcat 6 webapp container, so i don't need to to suply the librelaries myself? I'll try it tonight, thank you very much.
 
Mikel Gonzalez
Greenhorn
Posts: 4
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Sorry, you are right, I tried to say that I'm not using JSP pages...

I'm using tomcat 6 webapp container, so i don't need to to suply the librelaries myself? I'll try it tonight, thank you very much.
 
Tim Holloway
Saloon Keeper
Pie
Posts: 17989
47
Android Eclipse IDE Linux
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Mikel Gonzalez wrote:Sorry, you are right, I tried to say that I'm not using JSP pages...

I'm using tomcat 6 webapp container, so i don't need to to suply the librelaries myself? I'll try it tonight, thank you very much.


I think you'll find an el jar file in the TOMCAT_HOME/lib directory.
 
Mikel Gonzalez
Greenhorn
Posts: 4
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
I've removed the el-api-2.2.jar and el-impl-2.2.jar from the WEB_INF/lib, and checked that there is a el-api.jar on the tomcat6/lib directory. However I still have the same error when trying to execute my application:

Mar 5, 2011 5:46:05 PM com.sun.faces.lifecycle.ELResolverInitPhaseListener populateFacesELResolverForJsp
INFO: JSF1027: [/mywebapp.com] The ELResolvers for JSF were not registered with the JSP container.

I allready put this code in the web.xml file of the application.

<context-param>
<param-name>com.sun.faces.expressionFactory</param-name>
<param-value>com.sun.el.ExpressionFactoryImpl</param-value>
</context-param>

What else do I have to configure then?? Thanks again!!
 
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic