This week's giveaway is in the Spring forum.
We're giving away four copies of REST with Spring (video course) and have Eugen Paraschiv on-line!
See this thread for details.
The moose likes Struts and the fly likes problem while starting the tomcat at struts-config Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login

Win a copy of REST with Spring (video course) this week in the Spring forum!
JavaRanch » Java Forums » Frameworks » Struts
Bookmark "problem while starting the tomcat at struts-config" Watch "problem while starting the tomcat at struts-config" New topic

problem while starting the tomcat at struts-config

Raveendra Mutyala

Joined: Sep 10, 2005
Posts: 13
hi friends,
i had done an application related to struts in WSAD5.1.2 and wanted to run the same application on tomcat. so i had created a war file and deployed on tomcat. then it is raising and exception as follows:

Feb 3, 2006 2:22:51 PM org.apache.struts.action.ActionServlet handleConfigException
SEVERE: Parsing error processing resource path Path WEB-INF/struts-config.xml does not start with a "/" character
at org.apache.catalina.core.ApplicationContext.getResource(
at org.apache.catalina.core.ApplicationContextFacade.getResource(
at org.apache.struts.action.ActionServlet.parseModuleConfigFile(
at org.apache.struts.action.ActionServlet.initModuleConfig(
at org.apache.struts.action.ActionServlet.init(
at javax.servlet.GenericServlet.init(
at org.apache.catalina.core.StandardWrapper.loadServlet(
at org.apache.catalina.core.StandardWrapper.load(
at org.apache.catalina.core.StandardContext.loadOnStartup(
at org.apache.catalina.core.StandardContext.start(
at org.apache.catalina.core.ContainerBase.addChildInternal(
at org.apache.catalina.core.ContainerBase.addChild(
at org.apache.catalina.core.StandardHost.addChild(
at org.apache.catalina.core.StandardHostDeployer.install(
at org.apache.catalina.core.StandardHost.install(
at org.apache.catalina.startup.HostConfig.deployWARs(
at org.apache.catalina.startup.HostConfig.deployApps(
at org.apache.catalina.startup.HostConfig.start(
at org.apache.catalina.startup.HostConfig.lifecycleEvent(
at org.apache.catalina.util.LifecycleSupport.fireLifecycleEvent(
at org.apache.catalina.core.ContainerBase.start(
at org.apache.catalina.core.StandardHost.start(
at org.apache.catalina.core.ContainerBase.start(
at org.apache.catalina.core.StandardEngine.start(
at org.apache.catalina.core.StandardService.start(
at org.apache.catalina.core.StandardServer.start(
at org.apache.catalina.startup.Catalina.start(
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(
at sun.reflect.DelegatingMethodAccessorImpl.invoke(
at java.lang.reflect.Method.invoke(
at org.apache.catalina.startup.Bootstrap.start(
at org.apache.catalina.startup.Bootstrap.main(

i had tried to solve it, but could not get the solution.

Awaiting for your valuable replies..
Thanking you,
From ur true friend..
Lalitha Vydyula
Ranch Hand

Joined: Jul 20, 2005
Posts: 69
In web.xml you path for struts-config.xm should start with a "/"(front slash)

Raveendra Mutyala

Joined: Sep 10, 2005
Posts: 13
Thank You Very much .. for ur reply........
Lalitha Vydyula
Ranch Hand

Joined: Jul 20, 2005
Posts: 69
Did it work though
I agree. Here's the link:
subject: problem while starting the tomcat at struts-config
It's not a secret anymore!