This week's giveaway is in the EJB and other Java EE Technologies forum.
We're giving away four copies of EJB 3 in Action and have Debu Panda, Reza Rahman, Ryan Cuprak, and Michael Remijan on-line!
See this thread for details.
The moose likes BEA/Weblogic and the fly likes Can't find wsdl /wsdls/wsc11/wstx-wscoor-1.1-wsdl-200702.wsdl Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login


Win a copy of EJB 3 in Action this week in the EJB and other Java EE Technologies forum!
JavaRanch » Java Forums » Products » BEA/Weblogic
Bookmark "Can Watch "Can New topic
Author

Can't find wsdl /wsdls/wsc11/wstx-wscoor-1.1-wsdl-200702.wsdl

sam jsem
Greenhorn

Joined: Mar 12, 2011
Posts: 9
Dear all,

I have a very simple Struts 2 application I am attempting to deploy to Weblogic 10.3.3. It has no Web Services component to it all. However I seem to getting the following error: "Can't find wsdl /wsdls/wsc11/wstx-wscoor-1.1-wsdl-200702.wsdl".

--------------------------------------------------------------------------------

Here is my web.xml:

<?xml version="1.0" encoding="UTF-8"?>
<web-app xmlns="http://java.sun.com/xml/ns/javaee" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xsi:schemaLocation="http://java.sun.com/xml/ns/javaee http://java.sun.com/xml/ns/javaee/web-app_2_5.xsd" version="2.5">

<display-name>FHEO Portal</display-name>

<context-param>
<param-name>org.apache.tiles.impl.BasicTilesContainer.DEFINITIONS_CONFIG</param-name>
<param-value>/WEB-INF/tiles.xml</param-value>
</context-param>

<listener>
<listener-class>org.apache.struts2.tiles.StrutsTilesListener</listener-class>
</listener>

<filter>
<filter-name>struts2</filter-name>
<filter-class>org.apache.struts2.dispatcher.ng.filter.StrutsPrepareAndExecuteFilter</filter-class>
</filter>


<filter-mapping>
<filter-name>struts2</filter-name>
<url-pattern>/*</url-pattern>
</filter-mapping>

<welcome-file-list>
<welcome-file>index.html</welcome-file>
<welcome-file>index.jsp</welcome-file>
</welcome-file-list>
</web-app>

--------------------------------------------------------------------------------

Here is my struts configuration file: struts.xml

<?xml version="1.0" encoding="UTF-8" ?>
<!DOCTYPE struts PUBLIC "-//Apache Software Foundation//DTD Struts Configuration 2.0//EN" "http://struts.apache.org/dtds/struts-2.0.dtd">

<struts>

<constant name="struts.enable.DynamicMethodInvocation" value="false" />
<constant name="struts.devMode" value="false" />
<!--
-->

<package name="SCHO" extends="tiles-default">
<result-types>
<result-type name="tiles" class="org.apache.struts2.views.tiles.TilesResult" default="true"/>
</result-types>

<action name="FlashPage">
<result>flashPage.jsp</result>
</action>
</package>

</struts>

--------------------------------------------------------------------------------

I am the following error when I try to deploy a test build of my application to Weblogic 10.3.3.0:

Can't find wsdl /wsdls/wsc11/wstx-wscoor-1.1-wsdl-200702.wsdl

at weblogic.wsee.deploy.WSEEModule.prepare(WSEEModule.java:146)
at weblogic.wsee.deploy.AppDeploymentExtensionFactory.prepare(AppDeploymentExtensionFactory.java:147)
at weblogic.wsee.deploy.AppDeploymentExtensionFactory.access$100(AppDeploymentExtensionFactory.java:27)
at weblogic.wsee.deploy.AppDeploymentExtensionFactory$1.prepare(AppDeploymentExtensionFactory.java:427)
at weblogic.application.internal.flow.AppDeploymentExtensionFlow.prepare(AppDeploymentExtensionFlow.java:23)
at weblogic.application.internal.BaseDeployment$1.next(BaseDeployment.java:1223)
at weblogic.application.utils.StateMachineDriver.nextState(StateMachineDriver.java:41)
at weblogic.application.internal.BaseDeployment.prepare(BaseDeployment.java:367)
at weblogic.application.internal.SingleModuleDeployment.prepare(SingleModuleDeployment.java:43)
at weblogic.application.internal.DeploymentStateChecker.prepare(DeploymentStateChecker.java:154)
at weblogic.deploy.internal.targetserver.AppContainerInvoker.prepare(AppContainerInvoker.java:60)
at weblogic.deploy.internal.targetserver.operations.ActivateOperation.createAndPrepareContainer(ActivateOperation.java:208)
at weblogic.deploy.internal.targetserver.operations.ActivateOperation.doPrepare(ActivateOperation.java:98)
at weblogic.deploy.internal.targetserver.operations.AbstractOperation.prepare(AbstractOperation.java:217)
at weblogic.deploy.internal.targetserver.DeploymentManager.handleDeploymentPrepare(DeploymentManager.java:749)
at weblogic.deploy.internal.targetserver.DeploymentManager.prepareDeploymentList(DeploymentManager.java:1216)
at weblogic.deploy.internal.targetserver.DeploymentManager.handlePrepare(DeploymentManager.java:250)
at weblogic.deploy.internal.targetserver.DeploymentServiceDispatcher.prepare(DeploymentServiceDispatcher.java:160)
at weblogic.deploy.service.internal.targetserver.DeploymentReceiverCallbackDeliverer.doPrepareCallback(DeploymentReceiverCallbackDeliverer.java:171)
at weblogic.deploy.service.internal.targetserver.DeploymentReceiverCallbackDeliverer.access$000(DeploymentReceiverCallbackDeliverer.java:13)
at weblogic.deploy.service.internal.targetserver.DeploymentReceiverCallbackDeliverer$1.run(DeploymentReceiverCallbackDeliverer.java:47)
at weblogic.work.SelfTuningWorkManagerImpl$WorkAdapterImpl.run(SelfTuningWorkManagerImpl.java:528)
at weblogic.work.ExecuteThread.execute(ExecuteThread.java:201)
at weblogic.work.ExecuteThread.run(ExecuteThread.java:173)


--------------------------------------------------------------------------------

As I said: there is no Web Services component to this application. It is very simple deployment on Weblogic, yet I am getting this inscrutable error. Could someone please offer some advice regarding this issue?

Mustafa Amaragi
Greenhorn

Joined: Mar 10, 2011
Posts: 2
what are the jars you're having in your app?

i am having a similar exception as that I in including the jar "webservices-rt-2.2.1-1.jar"

here is the exception

weblogic.wsee.ws.WsException: Can't find wsdl /wsdls/wsc11/wstx-wscoor-1.1-wsdl-200702.wsdl
at weblogic.wsee.deploy.WSEEWebModule.loadWsdlDefinitions(WSEEWebModule.java:142)
at weblogic.wsee.deploy.WSEEModule.loadWsdl(WSEEModule.java:292)
at weblogic.wsee.deploy.WSEEModule.verifyWsdd(WSEEModule.java:147)
at weblogic.wsee.deploy.WSEEModule.prepare(WSEEModule.java:106)
at weblogic.wsee.deploy.ServletDeployListener.contextPrepared(ServletDeployListener.java:29)
Truncated. see log file for complete stacktrace
 
I agree. Here's the link: http://aspose.com/file-tools
 
subject: Can't find wsdl /wsdls/wsc11/wstx-wscoor-1.1-wsdl-200702.wsdl
 
Similar Threads
private variable holds value when returning to action
jsfcookmenu problem
Velocity + Struts2 + Sitemesh + Spring +Hibernate Integration How to configur web.xml?
Error with Struts 2 and Tiles 2
Exposing a java method as WebService