Two Laptop Bag*
The moose likes Other Java Products and Servers and the fly likes could not redeploy web application with libraries - Error in linking security policy Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login


Win a copy of OCA/OCP Java SE 7 Programmer I & II Study Guide this week in the OCPJP forum!
JavaRanch » Java Forums » Products » Other Java Products and Servers
Bookmark "could not redeploy web application with libraries - Error in linking security policy" Watch "could not redeploy web application with libraries - Error in linking security policy" New topic
Author

could not redeploy web application with libraries - Error in linking security policy

Pradyut Bhattacharya
Ranch Hand

Joined: Aug 12, 2004
Posts: 63
I m having an web application with few jar files namely:
commons-io-1.4.jar
commons-fileupload-1.2.1.jar
gdata-base-1.0.jar

first i could easily deploy the web application with the libraries without any problems
but for the second time i could not re deploy the application

i get the error:
Exception while loading the app : Error in linking security policy for void -- Inconsistent Module State

after renaming the jar files to _ wihtout the hyphen(-) i could deploy the application for the first time

but for the second time i could not re deploy the application

Now i consistently getting the error: -

Exception while loading the app : Error in linking security policy for void -- Inconsistent Module State
I think i will have fall back to glassfish 3.01 without the recent update

even doing this... deleting the _internal directory and restarting the server did not help

http://www.mentby.com/jacques-21/error-in-linking-security-policy-for-testing-inconsistent-module-state.html

I have issued this in jira

http://java.net/jira/browse/GLASSFISH-16238

and at glassfish forums
http://www.java.net/forum/topic/glassfish/glassfish/not-able-re-deploy-application-glassfish-301-1


the log files say that:-



Pradyut
http://pradyut.tk/
 
I agree. Here's the link: http://aspose.com/file-tools
 
subject: could not redeploy web application with libraries - Error in linking security policy