wood burning stoves 2.0*
The moose likes Object Relational Mapping and the fly likes Connection Pool (couldn't find datasource) Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login


Win a copy of Murach's Java Servlets and JSP this week in the Servlets forum!
JavaRanch » Java Forums » Databases » Object Relational Mapping
Bookmark "Connection Pool (couldn Watch "Connection Pool (couldn New topic
Author

Connection Pool (couldn't find datasource)

Michael Houlo
Ranch Hand

Joined: Jun 07, 2010
Posts: 58
Dear,

I'm trying to use my application server connection pool trought Hibernate.

When i use hibernate without a connection pool, it works.
When i use my connection pool without hibernate, it works.
When i use my connection pool with hibernate, i've got the following error :


my web.xml :

my geronimo.xml

my hibernate.cfg.xml


I use a "HibernateUtil" class, the error appears at the following code line :


Could you please tell me what am I missing ?
I tryed X different configurations, always the same problem..
Thanks a lot !
Arun Kumarr
Ranch Hand

Joined: May 16, 2005
Posts: 513

1. You might want to check JNDI naming conventions (in general and for geronimo).
2. Use Geronimo's Admin Interface to actually check under what name the JNDI object is bound. You can use that for looking up.

This Link might be helpful.


If you are not laughing at yourself, then you just didn't get the joke.
Michael Houlo
Ranch Hand

Joined: Jun 07, 2010
Posts: 58
I fixed it, thanks a lot anyway
David O'Meara
Rancher

Joined: Mar 06, 2001
Posts: 13459

Can you post the solution please?
I'm guessing your JNDI URL was incorrect.
Michael Houlo
Ranch Hand

Joined: Jun 07, 2010
Posts: 58
David O'Meara wrote:Can you post the solution please?
I'm guessing your JNDI URL was incorrect.


You're right.
I had to specify a new dependency in my geronimo-web.xml using this synthax : <dep:artifactId>jdbc_oracleJndi</dep:artifact>
and then link it this way :


Hope it helps.
 
I agree. Here's the link: http://aspose.com/file-tools
 
subject: Connection Pool (couldn't find datasource)
 
Similar Threads
Trying EJB3 from Eclipse WTP Book
Application stopped during the DBpool deployment
Problem with EJB lookup on GlassFish 2
404 Error on web application
JBoss 5.1.0.GA multiple datasource problem