File APIs for Java Developers
Manipulate DOC, XLS, PPT, PDF and many others from your application.
http://aspose.com/file-tools
The moose likes JBoss/WildFly and the fly likes Fail to start JBoss 4.0.5 and JBoss 4.2.2 in Eclipse Helios Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login
JavaRanch » Java Forums » Products » JBoss/WildFly
Bookmark "Fail to start JBoss 4.0.5 and JBoss 4.2.2 in Eclipse Helios" Watch "Fail to start JBoss 4.0.5 and JBoss 4.2.2 in Eclipse Helios" New topic
Author

Fail to start JBoss 4.0.5 and JBoss 4.2.2 in Eclipse Helios

Calson LI
Ranch Hand

Joined: Nov 18, 2005
Posts: 42
I started JBoss 4.0.5 using port 18080, and JBoss 4.2.2 using port 28080 because 8080 in localhost is used. But I failed to start them with error message "Server JBoss vx.x at localhost was unable to start within 65 seconds. If the server requires more time, try increasing the timeout in the server editor". I have tried to increase the time-out for starting JBoss 4.0.5 and JBoss 4.2.2 in Eclipse Helios. But the problem persisted.

The strange things are that I could start JBoss 4.0.5 and JBoss 4.2.2 in DOS environment by runing "run.bat" under JBossx.x\bin folder. Also, I could start these 2 application servers in Netbeans environment.

Is there any configuration I need to set-up in Eclipse Helios?

Thanks a lot for your assistance in advance.
Peter Johnson
author
Bartender

Joined: May 14, 2008
Posts: 5845
    
    7

See if this helps:
http://www.coderanch.com/t/496649/vc/Jboss-not-starting-eclipse


JBoss In Action
Calson LI
Ranch Hand

Joined: Nov 18, 2005
Posts: 42
Thanks Peter, the problem was solved.
Peter Johnson
author
Bartender

Joined: May 14, 2008
Posts: 5845
    
    7

Please tells us what you did to solve the problem. Your resolution could help others in the future when they come across your post.
Calson LI
Ranch Hand

Joined: Nov 18, 2005
Posts: 42
Dear Peter,

I change default port number, 8080 of JBoss 4.0.5.GA to 18080 at
  • "\jboss-4.0.5.GA\server\default\deploy\http-invoker.sar\META-INF\jboss-service.xml"; and
  • "\jboss-4.0.5.GA\server\default\deploy\jbossweb-tomcat55.sar\server.xml";


  • Also, I change the port number in eclipse for JBoss 4.0.5.GA to 18080.

    Since these port number matches, Jboss 4.0.5.GA can start properly in Eclipse.

    Thanks,
    Calson

     
    I agree. Here's the link: http://aspose.com/file-tools
     
    subject: Fail to start JBoss 4.0.5 and JBoss 4.2.2 in Eclipse Helios