• Post Reply
  • Bookmark Topic Watch Topic
  • New Topic

Jboss auto hot deployment issue

 
Sunny Ratra
Greenhorn
Posts: 5
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi All,

We are using Red Hat Enterprise Linux Server release 5.4 (Tikanga) environment and Jboss Application server 4.x
We are facing one problem of auto hot deployment in JBoss application server.
The war and xml present in deploy folder are automatically getting deployed in temp folder by Jboss HDScanner

Can any one please help me out to figure out this problem? if you have any idea related to JBoss HDScanner and auto hot deployment conditions please provide you comments.


Thanks in advance.

Sunny Ratra
 
Peter Johnson
author
Bartender
Posts: 5852
7
Android Eclipse IDE Ubuntu
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
That is the way that it works. The app server cannot run the app from packaged files, so it explodes them into the temp directory and runs them from there. You can, alternately, deploy exploded applications. See http://community.jboss.org/wiki/ExplodedDeployment
 
Sunny Ratra
Greenhorn
Posts: 5
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi Peter,

Thanks for your reply.

The problem we are facing on deployed application which is running fine on application server, some times any of the file(*.war, *.xml) present in deploy folder, Is automatically getting deployed again in temp folder (change in timestamp in temp/deploy folder for that file, which is not changing in main deploy directory ) and we are getting the redeployment logs in log file.

Now as per our observation it seems there is some thing that is triggering the redeployment of files(*.war, *.xml) in temp folder automatically in running and deployed application.

What is causing HD Scanner to do that redeployment in temp folder automatically?

Have any one observed this kind of problem?

Please share, your comments are appreciable.

Thanks in advance

Regards
Sunny Ratra
 
Jaikiran Pai
Marshal
Pie
Posts: 10447
227
IntelliJ IDE Ubuntu
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Sunny Ratra wrote:

Thanks for your reply.

The problem we are facing on deployed application which is running fine on application server, some times any of the file(*.war, *.xml) present in deploy folder, Is automatically getting deployed again in temp folder (change in timestamp in temp/deploy folder for that file, which is not changing in main deploy directory ) and we are getting the redeployment logs in log file.


Are you sure it's an application redeployment and not just some file being added to the tmp folder?
 
Sunny Ratra
Greenhorn
Posts: 5
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Jaikiran Pai wrote:
Sunny Ratra wrote:

Thanks for your reply.

The problem we are facing on deployed application which is running fine on application server, some times any of the file(*.war, *.xml) present in deploy folder, Is automatically getting deployed again in temp folder (change in timestamp in temp/deploy folder for that file, which is not changing in main deploy directory ) and we are getting the redeployment logs in log file.


Are you sure it's an application redeployment and not just some file being added to the tmp folder?


Well I can see the same file which is present in main deploy folder is coming in tmp/deploy folder with new time stamp.

For example: oracle-ds.xml is getting redeployed in temp folder again and again.
 
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic