File APIs for Java Developers
Manipulate DOC, XLS, PPT, PDF and many others from your application.
http://aspose.com/file-tools
The moose likes JSF and the fly likes tomahawk not working with JSF 1.2 and Facelets Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login
JavaRanch » Java Forums » Java » JSF
Bookmark "tomahawk not working with JSF 1.2 and Facelets " Watch "tomahawk not working with JSF 1.2 and Facelets " New topic
Author

tomahawk not working with JSF 1.2 and Facelets

vishnu bola
Ranch Hand

Joined: Jun 01, 2009
Posts: 32
Hi all,

I need help in fixing the error below when i add tomahawk1.1.10 to my project which uses JSF 1.2 and facelets and tomcat 6.0.

* Warning: This page calls for XML namespace http://myfaces.apache.org/tomahawk declared with prefix t but no taglibrary exists for that namespace.

I have this xhtml with whe tomahawk tag added as below

<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN"
"http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">
<html xmlns="http://www.w3.org/1999/xhtml"
xmlns:ui="http://java.sun.com/jsf/facelets"
xmlns:h="http://java.sun.com/jsf/html"
xmlns:f="http://java.sun.com/jsf/core"
xmlns:t="http://myfaces.apache.org/tomahawk">

please let me know if i need to add any other jars to make tomahawk work or any other thing which iam missing.

Thank you for your help in advance
Nischit Shetty
Greenhorn

Joined: Feb 21, 2007
Posts: 25
Please make sure you have the TLD files in your tomahawk jars. Sometime these jars may not have these TLDs at all. You may have to download the correct version
Ilari Moilanen
Ranch Hand

Joined: Apr 15, 2008
Posts: 198
I do not know how do you do it with JSF 1 but with JSF 2 I have this in web.xml file
and naturally I have the file mentioned in that location too.
Tim Holloway
Saloon Keeper

Joined: Jun 25, 2001
Posts: 15641
    
  15

If you're using Facelets, the TLD gets more or less ignored, but there's a facelets adapter XML file that you need. You can copy and paste it from the MyFaces website, where they explain it (more or less decently).

Also, of course, do make sure you have the right version of Tomahawk. MyFaces broke into 2 different distributions depending on what version of JSF you're working with.


Customer surveys are for companies who didn't pay proper attention to begin with.
vishnu bola
Ranch Hand

Joined: Jun 01, 2009
Posts: 32
hi all,

Thank you for all your valuable responses. I solved this issue by adding extension filter in my web.xml and it worked like a charm



Thank you once again
 
I agree. Here's the link: http://aspose.com/file-tools
 
subject: tomahawk not working with JSF 1.2 and Facelets
 
Similar Threads
Component javax.faces.component.UIViewRoot is no
xhtml or JSP
IceFaces question: using other components
XML namespace in a JSF 2.0
JSF2 Modal Dialog Box