aspose file tools*
The moose likes Web Services and the fly likes invoke remote webservice  APACHE ODE Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login
JavaRanch » Java Forums » Java » Web Services
Bookmark "invoke remote webservice  APACHE ODE" Watch "invoke remote webservice  APACHE ODE" New topic
Author

invoke remote webservice APACHE ODE

Y Rach
Greenhorn

Joined: Mar 29, 2011
Posts: 9
I created a project for example project HelloWorld2(ODE examples).
I try to invoke remote webservice on my machine.
It's wsdl and xsd files i added to HelloWorld2 project folder.

To remote webservice wsdl i added this code to invoke it's service

<WSDL:definitions
...
xmlns:plnk="http://docs.oasis-open.org/wsbpel/2.0/plnktype">

<plnk:partnerLinkType name="sbmadminservices72PartnerLinkType">
<plnk:role name="sbmadminservices72Provider" portType="tns:sbmadminservices72PortType"/>
</plnk:partnerLinkType>

and this code to main bpel file

<import location="sbmadminservices72.wsdl"
namespace="http://localhost:80/gsoap/sbmadminservices72.wsdl"
importType="http://schemas.xmlsoap.org/wsdl/" />


<partnerLinks>

...

<partnerLink name="sbmadminservices72PartnerLink"
partnerLinkType="test2:sbmadminservices72PartnerLinkType"
myRole="sbmadminservices72Provider" />

</partnerLinks>


There is no errors while deploying at ode log file ( i have switched log level to TRACE)

But when i using SopaUI to post request to this project end-point ...I received an error

<faultcode>soapenv:Client</faultcode>
<faultstring>The service cannot be found for the endpoint reference (EPR) http://localhost:8080/ode/processes/helloWorld</faultstring>;
<detail>
<Exception>org.apache.axis2.AxisFault: The service cannot be found for the endpoint reference (EPR) http://localhost:8080/ode/processes/helloWorld
.....


Where was my mistake ?

this is my project ->>>>>>>>>DOWNLOAD
Ravinderjit Singh
Ranch Hand

Joined: Jan 13, 2010
Posts: 78
ODE is unable to find the wsdl.

check if you can see the wsdl at this address?

http://localhost:8080/ode/processes/helloWorld?wsdl
Y Rach
Greenhorn

Joined: Mar 29, 2011
Posts: 9
Thanks, I already found the problem.

It was that...ode compile deployed project only once...at the first meeting of a new project.
 
I agree. Here's the link: http://aspose.com/file-tools
 
subject: invoke remote webservice APACHE ODE