This week's giveaway is in the EJB and other Java EE Technologies forum.
We're giving away four copies of EJB 3 in Action and have Debu Panda, Reza Rahman, Ryan Cuprak, and Michael Remijan on-line!
See this thread for details.
The moose likes Struts and the fly likes Login page is not opening Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login


Win a copy of EJB 3 in Action this week in the EJB and other Java EE Technologies forum!
JavaRanch » Java Forums » Frameworks » Struts
Bookmark "Login page is not opening" Watch "Login page is not opening" New topic
Author

Login page is not opening

swamy patel
Greenhorn

Joined: Apr 07, 2011
Posts: 1


Hi,
I am new to struts. I have a struts application using struts 1.3.10 and the server is WAS7 on RAD. I have used the following files

struts-bean.tld
struts-logic.tld
struts-html.tld
struts-config.xml
error.jsp
logon.jsp
logonaction.java


in the struts- config.xml i have provided

<action path="/logon" parameter="method"
type="com.myapp.action.LogonAction" name="logonForm"
scope="request" validate="true">
<forward name="logon" path="/pages/logon.jsp" />
</action>


The issue is when i give the url of login page in the browser, the error page is displayed. in the console the following exception is occuring

[4/7/11 15:25:40:264 IST] 0000001f servlet I com.ibm.ws.webcontainer.servlet.ServletWrapper init SRVE0242I:[/pages/error.jsp]: Initialization successful.
[4/7/11 15:28:18:220 IST] 0000001f FfdcProvider I com.ibm.ws.ffdc.impl.FfdcProvider logIncident FFDC1003I: FFDC Incident emitted on C:\Program Files\ibm\SDP\runtimes\base_v7\profiles\AppSrv01\logs\ffdc\server1_126b126b_11.04.07_15.28.17.9233664201368554090176.txt com.ibm.ws.webcontainer.webapp.WebApp.handleRequest 985
[4/7/11 15:28:18:236 IST] 0000001f webapp E com.ibm.ws.webcontainer.webapp.WebApp logError SRVE0293E: [Servlet Error]-[java.lang.NullPointerException]: java.lang.NullPointerException
at com.ibm.ws.webcontainer.servlet.ServletWrapper.handleRequest(ServletWrapper.java:495)
at com.ibm.ws.webcontainer.servlet.ServletWrapper.handleRequest(ServletWrapper.java:475)
at com.ibm.ws.webcontainer.servlet.ServletWrapperImpl.handleRequest(ServletWrapperImpl.java:175)
at com.ibm.wsspi.webcontainer.servlet.GenericServletWrapper.handleRequest(GenericServletWrapper.java:121)
at com.ibm.ws.jsp.webcontainerext.AbstractJSPExtensionServletWrapper.handleRequest(AbstractJSPExtensionServletWrapper.java:239)
at com.ibm.ws.webcontainer.webapp.WebApp.handleRequest(WebApp.java:3799)
at com.ibm.ws.webcontainer.webapp.WebGroup.handleRequest(WebGroup.java:276)
at com.ibm.ws.webcontainer.WebContainer.handleRequest(WebContainer.java:930)
at com.ibm.ws.webcontainer.WSWebContainer.handleRequest(WSWebContainer.java:1583)
at com.ibm.ws.webcontainer.channel.WCChannelLink.ready(WCChannelLink.java:182)
at com.ibm.ws.http.channel.inbound.impl.HttpInboundLink.handleDiscrimination(HttpInboundLink.java:455)
at com.ibm.ws.http.channel.inbound.impl.HttpInboundLink.handleNewInformation(HttpInboundLink.java:384)
at com.ibm.ws.http.channel.inbound.impl.HttpInboundLink.ready(HttpInboundLink.java:272)
at com.ibm.ws.tcp.channel.impl.NewConnectionInitialReadCallback.sendToDiscriminators(NewConnectionInitialReadCallback.java:214)
at com.ibm.ws.tcp.channel.impl.NewConnectionInitialReadCallback.complete(NewConnectionInitialReadCallback.java:113)
at com.ibm.ws.tcp.channel.impl.AioReadCompletionListener.futureCompleted(AioReadCompletionListener.java:165)
at com.ibm.io.async.AbstractAsyncFuture.invokeCallback(AbstractAsyncFuture.java:217)
at com.ibm.io.async.AsyncChannelFuture.fireCompletionActions(AsyncChannelFuture.java:161)
at com.ibm.io.async.AsyncFuture.completed(AsyncFuture.java:138)
at com.ibm.io.async.ResultHandler.complete(ResultHandler.java:204)
at com.ibm.io.async.ResultHandler.runEventProcessingLoop(ResultHandler.java:775)
at com.ibm.io.async.ResultHandler$2.run(ResultHandler.java:905)
at com.ibm.ws.util.ThreadPool$Worker.run(ThreadPool.java:1550)



Please help.
Thanks





 
I agree. Here's the link: http://aspose.com/file-tools
 
subject: Login page is not opening
 
Similar Threads
Struts Global forward not recognized
Struts 2.0 application not working in WAS 6.1 server
Configuring WAS 6.1 data source
OutOfMemoryError in WAS6.1
Cannot access application running in WAS 6.1 test server in RAD