This week's book giveaway is in the JavaScript forum.
We're giving away four copies of Getting MEAN with Mongo, Express, Angular, and Node and have Simon Holmes on-line!
See this thread for details.
The moose likes Tomcat and the fly likes APR not loaded despite libapr and libtcnative installed Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login


JavaRanch » Java Forums » Products » Tomcat
Bookmark "APR not loaded despite libapr and libtcnative installed" Watch "APR not loaded despite libapr and libtcnative installed" New topic
Author

APR not loaded despite libapr and libtcnative installed

Oernii oernii
Greenhorn

Joined: Apr 08, 2011
Posts: 1
Hi, my tomcat does not load APR, despite that libtcnative and libapr present at the system. It even gest loaded into the java process itself:

[pid 4748] open("/usr/lib/libtcnative-1.so.0.1.20", O_RDONLY) = 55
[pid 4748] open("/usr/lib/libapr-1.so.0", O_RDONLY) = 55


but a few lines lower it prints:
Apr 8, 2011 4:19:47 PM org.apache.catalina.core.AprLifecycleListener lifecycleEvent
INFO: The Apache Tomcat Native library which allows optimal performance in production environments was not found on the java.library.path: /usr/lib/jvm/java-1.6.0-sun-1.6.0.22/jre/lib/i386/server:/usr/lib/jvm/j
ava-1.6.0-sun-1.6.0.22/jre/lib/i386:/usr/lib/jvm/java-1.6.0-sun-1.6.0.22/jre/../lib/i386:/usr/java/packages/lib/i386:/lib:/usr/lib


Can anyone help me figure out that one?

PS: i686 linux MDV 2010.1, 2.6.33.5-server-2mnb, java 1.6.0_22-b04

 
It is sorta covered in the JavaRanch Style Guide.
 
subject: APR not loaded despite libapr and libtcnative installed