File APIs for Java Developers
Manipulate DOC, XLS, PPT, PDF and many others from your application.
http://aspose.com/file-tools
The moose likes Struts and the fly likes No configuration found for the specified action: Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login
JavaRanch » Java Forums » Frameworks » Struts
Bookmark "No configuration found for the specified action: " Watch "No configuration found for the specified action: " New topic
Author

No configuration found for the specified action:

Nelson Castor
Greenhorn

Joined: Apr 13, 2011
Posts: 1
Hey guys,

First off, I just wanted to say thanks in advance for the help. I encountered this site many times through searches while I tried to pick up the fundamentals of Struts2. Now, on to my problem. Rest assured, I did scour many of the similar issues, and I never really found one that quite clicked in a way that resolved my issue.

I have two problems; the first of which relates to the "No configuration found for the specified action" issue. Here is the text from the error:
WARNING: No configuration found for the specified action: 'proceed' in namespace: ''. Form action defaulting to 'action' attribute's literal value.

That brings me two my second issue. I'm not sure if they're related, but if they are, I would greatly appreciate some insight as to how these are connected. I have a simple form with a couple required fields. After clicking submit, the error messages are displayed when there is no string present (since I'm using the "requiredstring" validation) -- all works here. However, even if I enter the correct text (i.e., any text at all), my fields are cleared and I am redirected back to the input page, the result of which is designated as the "input" result for determining which page to navigate to. I'll post my struts.xml and my JSP page. If anyone can help me out, that would be greatly appreciated!

Struts.xml:


index.jsp (note: the form is the issue, here):


Also, I forgot to mention that I tried a number of variations with the form. I attempted to include "/proceed," "/proceed.action," "proceed.action," etc. for the action. I also attempted to include the namespace identical to the package above, which also didn't seem to work. This threw an error with a yellow highlight and lots of red!

If someone can help me to determine if these two issues are related, that would be amazing. I was under the impression that, since the system wasn't detecting my actual action code, it wasn't redirecting to the subsequent page correctly; of course, I'm brand new to Struts2, and this could be completely unrelated. Either way, thanks!
 
I agree. Here's the link: http://aspose.com/file-tools
 
subject: No configuration found for the specified action: