• Post Reply
  • Bookmark Topic Watch Topic
  • New Topic

Unable to find run.bat file in bin folder in jboss7

 
Ganeshkumar cheekati
Ranch Hand
Posts: 362
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi
i downloaded jboss7 in which unable to find run.bat file in bin folder.so how can i start jboss manually?
i have found standalone.bat file which i used to execute this in cmd by giving following variables
i set JAVA_HOME:\Program Files\Java\jdk1.5.0_06
JBOSS_HOME:\gani\jboss-7.0.0.Beta2\jboss-7.0.0.Beta2
CLASSPATH:\Program Files\Java
but getting the following error:



D:\gani\jboss-7.0.0.Beta2\jboss-7.0.0.Beta2>cd bin

D:\gani\jboss-7.0.0.Beta2\jboss-7.0.0.Beta2\bin>standalone.bat
Config file not found D:\gani\jboss-7.0.0.Beta2\jboss-7.0.0.Beta2\bin\standalone
.conf.bat
===============================================================================

JBoss Bootstrap Environment

JBOSS_HOME: D:\gani\jboss-7.0.0.Beta2\jboss-7.0.0.Beta2

JAVA: D:\Program Files\Java\jdk1.5.0_06\bin\java

JAVA_OPTS: -Dprogram.name=standalone.bat -server

===============================================================================

Exception in thread "main" java.lang.UnsupportedClassVersionError: Bad version n
umber in .class file
at java.lang.ClassLoader.defineClass1(Native Method)
at java.lang.ClassLoader.defineClass(ClassLoader.java:620)
at java.security.SecureClassLoader.defineClass(SecureClassLoader.java:12
4)
at java.net.URLClassLoader.defineClass(URLClassLoader.java:260)
at java.net.URLClassLoader.access$100(URLClassLoader.java:56)
at java.net.URLClassLoader$1.run(URLClassLoader.java:195)
at java.security.AccessController.doPrivileged(Native Method)
at java.net.URLClassLoader.findClass(URLClassLoader.java:188)
at java.lang.ClassLoader.loadClass(ClassLoader.java:306)
at sun.misc.Launcher$AppClassLoader.loadClass(Launcher.java:268)
at java.lang.ClassLoader.loadClass(ClassLoader.java:251)
at java.lang.ClassLoader.loadClassInternal(ClassLoader.java:319)
Press any key to continue . . .

Can anyone help me?
 
Jaikiran Pai
Marshal
Pie
Posts: 10447
227
IntelliJ IDE Ubuntu
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
JBoss AS7 is in Beta stages and is drastically different from the previous versions of JBoss AS. If you want to use JBoss AS7, then follow this http://community.jboss.org/wiki/JBossAS7UserGuide.

If you want to use a stable version of JBoss AS, then the latest one is JBoss AS 6.0.0.Final.
 
Jaikiran Pai
Marshal
Pie
Posts: 10447
227
IntelliJ IDE Ubuntu
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Also, JBoss AS6 and AS7 will require Java 6 to run. It won't run on Java 5 (the version you are using).
 
Ganeshkumar cheekati
Ranch Hand
Posts: 362
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
okay thanks a lot..
 
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic