Win a copy of Mesos in Action this week in the Cloud/Virtualizaton forum!
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic

Application is not working in jboss which worked on tomcat?

 
Ganeshkumar cheekati
Ranch Hand
Posts: 362
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi,
i copied my war file in j boss-5.0.1.GA\server\default\deploy folder and i started the server using run.bat in bin folder. its started with out any problem so i accessed my application with link http://localhost:8080/application_name and got home page but if i try to login getting webpage not found.

My application developed using struts2 framework.

My doubts are

1) After server started application folder is not being created for example my application is sample.war file so server should have to explode it and create sample folder with files.

2) i deployed same application in tomcat and worked fine why its not working in j boss. do i have to set anything for this server.

3) did i deploy my war file in correct location?

its created one log file for my application and it contains error as follows


Can anyone please clarify me?
thanks in advance
 
vani venkat
Ranch Hand
Posts: 142
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
did you search for file application_name in jboss folders.
mine created folders in some temp location.
C:\jboss-6\server\default\tmp\vfs\vfsinmemory62f86dafefe63eef\sa.war

my was file was sa.war. it had all the files and folders.



 
Ganeshkumar cheekati
Ranch Hand
Posts: 362
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
yeah exploded folder created in temp folder with all the files.

but its not working fine.
 
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic