File APIs for Java Developers
Manipulate DOC, XLS, PPT, PDF and many others from your application.
http://aspose.com/file-tools
The moose likes Tomcat and the fly likes Tomcat 5.5.30 and IIS 5 Configuration problem Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login


Win a copy of EJB 3 in Action this week in the EJB and other Java EE Technologies forum!
JavaRanch » Java Forums » Products » Tomcat
Bookmark "Tomcat 5.5.30 and IIS 5 Configuration problem" Watch "Tomcat 5.5.30 and IIS 5 Configuration problem" New topic
Author

Tomcat 5.5.30 and IIS 5 Configuration problem

Ravi Sree
Ranch Hand

Joined: Jan 24, 2010
Posts: 62

Hi All,

I am trying to set up Tomcat 5.5.30 and IIS 5.1 on a Windows XP SP3 system.
As per the url: -
The Apache Tomcat Connector - Reference Guide
The ISAPI filter is registered correctly in IIS, by that I mean the arrow is green indicating successful installation.
I have the worker.properties and uriworkermap.properties in the <CATALINA_HOME>/conf directory.
worker.properties

# An entry that lists all the workers defined
worker.list=jspexampleworker
worker.jspexampleworker.host=localhost
worker.jspexampleworker.port=8009
worker.jspexampleworker.type=ajp13

uriworkermap.properties

# Mapping the URI /jsp-examples and everything under /jsp-examples/:
/jsp-examples=jspexampleworker
/jsp-examples/*=jspexampleworker
# Mapping all URI which end with a common suffix:
*.jsp=jspexampleworker
*.html=jspexampleworker

I placed .dll file (isapi_redirect-1.2.31.dll) in the <CATALINA_HOME>/bin directory
I followed the registry entries as showed and also created the virtual directory as specified.
And when i go to the url http://localhost/jsp-examples it is showing this error

Bad Gateway!
There is a problem with the page you are looking for, and it cannot be displayed. When the Web server (while acting as a gateway or proxy) contacted the upstream content server, it received an invalid response from the content server.
Jakarta/ISAPI/isapi_redirector/1.2.31(1026297)


I don’t know what i am missing here, and would really appreciate some suggestions.

Regards,
Sree
William Brogden
Author and all-around good cowpoke
Rancher

Joined: Mar 22, 2000
Posts: 12676
    
    5
In the Tomcat server.xml configuration file, what port is the Connector set for?

Can you get a response directly from that port to confirm that Tomcat is running?

Bill

Java Resources at www.wbrogden.com
Ravi Sree
Ranch Hand

Joined: Jan 24, 2010
Posts: 62

William Brogden wrote:In the Tomcat server.xml configuration file, what port is the Connector set for?

Can you get a response directly from that port to confirm that Tomcat is running?

Bill


Hi William,

Thanks for replying,

I have checked the 'server.xml' in the <CATALINA_HOME>/conf directory, and the port for the connector set is the same('8009').

<!-- Define an AJP 1.3 Connector on port 8009 -->
<Connector port="8009"
enableLookups="false" redirectPort="8443" protocol="AJP/1.3" />

Although I intentionally start Tomcat, i don't know how i can find out if i could any response from that port.
Please suggest if i am missing some point here.

Regards,
Sree
 
I agree. Here's the link: http://aspose.com/file-tools
 
subject: Tomcat 5.5.30 and IIS 5 Configuration problem
 
Similar Threads
IIS with Tomcat integration on Windows XP
Going nuts with Tomcat 4, JK2, and IIS
Problems connecting IIS and tomcat
JK2 with IIS5 in WIn2000 sp4 not running
Apache Tomcat Connector error "did not find a worker ajp13"