This week's book giveaway is in the OCPJP forum.
We're giving away four copies of OCA/OCP Java SE 7 Programmer I & II Study Guide and have Kathy Sierra & Bert Bates on-line!
See this thread for details.
The moose likes BEA/Weblogic and the fly likes Weblogic not starting Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login


Win a copy of OCA/OCP Java SE 7 Programmer I & II Study Guide this week in the OCPJP forum!
JavaRanch » Java Forums » Products » BEA/Weblogic
Bookmark "Weblogic not starting" Watch "Weblogic not starting" New topic
Author

Weblogic not starting

Shanavas Habeeb
Greenhorn

Joined: Apr 18, 2011
Posts: 3
Hi,

I am not able to start my weblogic server.
Its giving the below given error. Please help

<Apr 18, 2011 4:50:16 PM PDT> <Emergency> <WebLogicServer> <BEA-000342> <Unable to initialize the server: java.lang.NumberFormatException: null>
***************************************************************************
The WebLogic Server did not start up properly.
java.lang.NumberFormatException: null
at java.lang.Integer.parseInt(Integer.java:436)
at java.lang.Integer.<init>(Integer.java:609)
at weblogic.ldap.EmbeddedLDAP.validateVDEDirectories(EmbeddedLDAP.java:1070)
at weblogic.ldap.EmbeddedLDAP.initialize(EmbeddedLDAP.java:197)
at weblogic.t3.srvr.T3Srvr.initializeHere(T3Srvr.java:816)
at weblogic.t3.srvr.T3Srvr.initialize(T3Srvr.java:670)
at weblogic.t3.srvr.T3Srvr.run(T3Srvr.java:344)
at weblogic.Server.main(Server.java:32)
Reason: java.lang.NumberFormatException: null
***************************************************************************


I tried to execute the deploy.sh program and got the message as given below.
ep-prdapp1(hyperion) # sh undeploy.sh
CLASSPATH=/portalsw/bea/jdk142_04/lib/tools.jar:/portalsw/bea/weblogic81/server/lib/weblogic_sp.jar:/portalsw/bea/weblogic81/server/lib/weblogic.jar:

PATH=/portalsw/bea/weblogic81/server/bin:/portalsw/bea/jdk142_04/jre/bin:/portalsw/bea/jdk142_04/bin:/portalsw/hyperion/common/utilities/Jikes/1.2.2:/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/usr/local/sbin:/opt/sfw/bin:/usr/ucb:/opt/VRTSvxfs/sbin:/opt/VRTSvlic/bin:/opt/VRTS/bin:/usr/sfw/bin

Your environment has been set.
Unable to connect to server t3://ep-prdapp1:10080 as user hyperion.
Reason: javax.naming.CommunicationException [Root exception is java.net.ConnectException: t3://ep-prdapp1:10080: Destination unreachable; nested exception is:
java.net.ConnectException: Connection refused; No available router to destination]
at weblogic.jndi.internal.ExceptionTranslator.toNamingException(ExceptionTranslator.java:47)
at weblogic.jndi.WLInitialContextFactoryDelegate.toNamingException(WLInitialContextFactoryDelegate.java:618)
at weblogic.jndi.WLInitialContextFactoryDelegate.getInitialContext(WLInitialContextFactoryDelegate.java:306)
at weblogic.jndi.Environment.getContext(Environment.java:166)
at weblogic.jndi.Environment.getInitialContext(Environment.java:145)
at weblogic.management.deploy.utils.MBeanHomeTool.getMBeanHome(MBeanHomeTool.java:172)
at weblogic.Deployer.runBody(Deployer.java:709)
at weblogic.utils.compiler.Tool.run(Tool.java:146)
at weblogic.utils.compiler.Tool.run(Tool.java:103)
at weblogic.Deployer.runMain(Deployer.java:566)
at weblogic.Deployer.main(Deployer.java:549)
Caused by: java.net.ConnectException: t3://ep-prdapp1:10080: Destination unreachable; nested exception is:
java.net.ConnectException: Connection refused; No available router to destination
at weblogic.rjvm.RJVMFinder.findOrCreate(RJVMFinder.java:199)
at weblogic.rjvm.ServerURL.findOrCreateRJVM(ServerURL.java:125)
at weblogic.jndi.WLInitialContextFactoryDelegate.getInitialContext(WLInitialContextFactoryDelegate.java:296)
... 8 more

Check option -adminurl, -username and -password.
anandraj tadkal
Ranch Hand

Joined: Feb 22, 2011
Posts: 98

This is an issue with the replication of the Embedded LDAP updates and is defined by the replicas.prop property file.

Find user_domain \ user_server \ ldap \ conf \ replicas.prop, edit this file, deleted all the content and add the following text:
Replica.num = 0

Re-start the server.

Note: You can back up the replicas.prop file before editing it.

Regards,
Anandraj
http://weblogic-wonders.com/


Regards,
Anandraj
http://weblogic-wonders.com
Follow us on facebook:
https://www.facebook.com/weblogicwonders
Shanavas Habeeb
Greenhorn

Joined: Apr 18, 2011
Posts: 3
Hi Anandraj,

I tried this but still my wblogic is not starting.
We have independent weblogic instalation for our modules like one for planning, one for shared services, one for eas etc.

Just give more information the file replicas.prop was a blank file when I opened it.
Please help me.

Thanks and Regards
Shanavas NH.
Shanavas Habeeb
Greenhorn

Joined: Apr 18, 2011
Posts: 3
Hi Anandraj,

I tried it as replica.num=0 without the space and it worked.
Thanks a lot for the help. I appreciate that.

Thanks and Regards
Shanavas N H
 
I agree. Here's the link: http://aspose.com/file-tools
 
subject: Weblogic not starting