aspose file tools*
The moose likes GWT and the fly likes Post upgradation problems Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login


Win a copy of Spring in Action this week in the Spring forum!
JavaRanch » Java Forums » Frameworks » GWT
Bookmark "Post upgradation problems" Watch "Post upgradation problems" New topic
Author

Post upgradation problems

Mohit J Kumar
Ranch Hand

Joined: Apr 08, 2010
Posts: 31

Hi,

I have upgraded to GWT-2.2.0 from GWT-2.0.4 and after the update I am
getting compilation errors. Here I am attaching a piece of stack
trace . Complete stack trace can be provided if anyone needs it.I am
using ANT 1.7.1 to build my project. All of the problems are in
gwt-user.jar and one in
gwt.dnd.jar

[ERROR] Errors in 'jar:file:/C:/Programs/tools/gwt-2.2.0/gwt-
user.jar!/com/google/gwt/emul/java/math/BitLevel.java'
[ERROR] Line 55: val.sign cannot be resolved or is not a field
[ERROR] Line 59: The method getFirstNonzeroDigit() is undefined
for the type BigInteger
[ERROR] Line 60: val.sign cannot be resolved or is not a field
[ERROR] Line 61: val.numberLength cannot be resolved or is not a
field
[ERROR] Line 62: val.digits cannot be resolved or is not a field
[ERROR] Line 67: val.digits cannot be resolved or is not a field
[ERROR] Line 68: val.numberLength cannot be resolved or is not a
field
[ERROR] Line 69: val.digits cannot be resolved or is not a field
[ERROR] Line 72: val.numberLength cannot be resolved or is not a
field
[ERROR] Line 83: val.sign cannot be resolved or is not a field
[ERROR] Line 86: val.numberLength cannot be resolved or is not a
field
[ERROR] Line 87: val.digits cannot be resolved or is not a field
[ERROR] Line 87: val.numberLength cannot be resolved or is not a
field
[ERROR] Line 89: val.sign cannot be resolved or is not a field
[ERROR] Line 90: The method getFirstNonzeroDigit() is undefined
for the type BigInteger

===================================================================

[ERROR] Errors in 'jar:file:/C:/IRIS/Projects/Releases/core-client/
release/gwt/war/WEB-INF/lib/gwt-dnd-3.0.0.jar!/com/allen_sauer/gwt/dnd/
client/util/DragClientBundle.java'
[ERROR] Internal compiler error
java.lang.IncompatibleClassChangeError: Found interface
com.google.gwt.core.ext.typeinfo.JClassType, but class was expected
at
com.google.gwt.resources.rg.CssResourceGenerator.computeOperableTypes(CssResourceGenerator.java:
587)
at
com.google.gwt.resources.rg.CssResourceGenerator.initReplacements(CssResourceGenerator.java:
682)
at
com.google.gwt.resources.rg.CssResourceGenerator.init(CssResourceGenerator.java:
461)
at
com.google.gwt.resources.rebind.context.AbstractClientBundleGenerator.initAndPrepare(AbstractClientBundleGenerator.java:
615)
at
com.google.gwt.resources.rebind.context.AbstractClientBundleGenerator.initAndPrepare(AbstractClientBundleGenerator.java:
654)
at
com.google.gwt.resources.rebind.context.AbstractClientBundleGenerator.generate(AbstractClientBundleGenerator.java:
243)
at
com.google.gwt.core.ext.GeneratorExtWrapper.generate(GeneratorExtWrapper.java:
48)
at
com.google.gwt.core.ext.GeneratorExtWrapper.generateIncrementally(GeneratorExtWrapper.java:
60)
at
com.google.gwt.dev.javac.StandardGeneratorContext.runGeneratorIncrementally(StandardGeneratorContext.java:
662)
at
com.google.gwt.dev.cfg.RuleGenerateWith.realize(RuleGenerateWith.java:
41)
at com.google.gwt.dev.shell.StandardRebindOracle
$Rebinder.rebind(StandardRebindOracle.java:74)
at
com.google.gwt.dev.shell.StandardRebindOracle.rebind(StandardRebindOracle.java:
259)
at
com.google.gwt.dev.shell.StandardRebindOracle.rebind(StandardRebindOracle.java:
248)
at
com.google.gwt.dev.DistillerRebindPermutationOracle.getAllPossibleRebindAnswers(DistillerRebindPermutationOracle.java:
91)
at
com.google.gwt.dev.jdt.WebModeCompilerFrontEnd.doFindAdditionalTypesUsingRebinds(WebModeCompilerFrontEnd.java:
106)
at com.google.gwt.dev.jdt.AbstractCompiler$Sandbox
$CompilerImpl.process(AbstractCompiler.java:254)
at
org.eclipse.jdt.internal.compiler.Compiler.compile(Compiler.java:444)
at com.google.gwt.dev.jdt.AbstractCompiler$Sandbox
$CompilerImpl.compile(AbstractCompiler.java:175)
at com.google.gwt.dev.jdt.AbstractCompiler$Sandbox
$CompilerImpl.compile(AbstractCompiler.java:288)
at com.google.gwt.dev.jdt.AbstractCompiler$Sandbox
$CompilerImpl.access$400(AbstractCompiler.java:145)

================================================================

[ERROR] Unexpected
java.lang.IncompatibleClassChangeError: Found interface
com.google.gwt.core.ext.typeinfo.JClassType, but class was expected
at
com.google.gwt.resources.rg.CssResourceGenerator.computeOperableTypes(CssResourceGenerator.java:
587)
at
com.google.gwt.resources.rg.CssResourceGenerator.initReplacements(CssResourceGenerator.java:
682)
at
com.google.gwt.resources.rg.CssResourceGenerator.init(CssResourceGenerator.java:
461)
at
com.google.gwt.resources.rebind.context.AbstractClientBundleGenerator.initAndPrepare(AbstractClientBundleGenerator.java:
615)
at
com.google.gwt.resources.rebind.context.AbstractClientBundleGenerator.initAndPrepare(AbstractClientBundleGenerator.java:
654)
at
com.google.gwt.resources.rebind.context.AbstractClientBundleGenerator.generate(AbstractClientBundleGenerator.java:
243)
at
com.google.gwt.core.ext.GeneratorExtWrapper.generate(GeneratorExtWrapper.java:
48)
at
com.google.gwt.core.ext.GeneratorExtWrapper.generateIncrementally(GeneratorExtWrapper.java:
60)
at
com.google.gwt.dev.javac.StandardGeneratorContext.runGeneratorIncrementally(StandardGeneratorContext.java:
662)
at
com.google.gwt.dev.cfg.RuleGenerateWith.realize(RuleGenerateWith.java:
41)
at com.google.gwt.dev.shell.StandardRebindOracle
$Rebinder.rebind(StandardRebindOracle.java:74)
at
com.google.gwt.dev.shell.StandardRebindOracle.rebind(StandardRebindOracle.java:
259)
at
com.google.gwt.dev.shell.StandardRebindOracle.rebind(StandardRebindOracle.java:
248)
at
com.google.gwt.dev.DistillerRebindPermutationOracle.getAllPossibleRebindAnswers(DistillerRebindPermutationOracle.java:
91)
at
com.google.gwt.dev.jdt.WebModeCompilerFrontEnd.doFindAdditionalTypesUsingRebinds(WebModeCompilerFrontEnd.java:
106)

Any help ???
Thanks


"It's good to B in touch...So keep responding"
 
I agree. Here's the link: http://aspose.com/file-tools
 
subject: Post upgradation problems