Win a copy of Mesos in Action this week in the Cloud/Virtualizaton forum!
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic

The import com.google cannot be resolved

 
karen keight
Greenhorn
Posts: 2
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi please help

when compiling in Eclipse 3.4.2 I get the message:
"The import com.google cannot be resolved"

I think that I need the google plug in.. I'm trying to install it from here:

http://code.google.com/intl/es-ES/eclipse/docs/getting_start ed.html#installing

But I follow the guidelines and when in Eclipse I go to
Software Updates/Available Software /Add site and when Install I get the message:

Cannot complete the request. See the details:
Unsatisfied dependency: requiredCapability: org.eclipse.equinox.p2.iu/org.eclipse.mylyn.commons.ui/0.0.0
Unsatisfied dependency: requiredCapability: org.eclipse.equinox.p2.iu/org.eclipse.mylyn.commons.ui/0.0.0
Unsatisfied dependency: requiredCapability: osgi.bundle/org.eclipse.mylyn.commons.net/[3.0.0,4.0.0)
Unsatisfied dependency: requiredCapability: osgi.bundle/org.eclipse.mylyn.commons.net/[3.0.0,4.0.0)
Unsatisfied dependency: requiredCapability: osgi.bundle/org.eclipse.mylyn.commons.ui/[3.0.0,4.0.0)
 
Ramon Anger
Ranch Hand
Posts: 56
Chrome Eclipse IDE Java
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi Karen,

p2 (your first unsatisfied dependency) is the replacement for the eclipse update manager in ganymede. Without it it's not that easy to install google web toolkit. For me it locks like your eclipse version is not up to date. Please try to Help -> Software Updates to check whether your Eclipse core can be updated.

Regards,
Ramon
 
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic