• Post Reply
  • Bookmark Topic Watch Topic
  • New Topic

No Window/Preferences/Server menu in Ubuntu

 
Bai Shen
Ranch Hand
Posts: 323
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
I'm running Ubuntu 11.04, with Eclipse 3.5.2 installed from the repository. Everywhere I've searched, I'm told to go to the Window/Preferences/Sever/Runtime Environments menu to configure Tomcat to run in Eclipse. But I don't seem to have a Server section.

I have the following.
  • General
  • Ant
  • Help
  • Install/Update
  • Java
  • Plug-in Development
  • Run/Debug
  • Team


  • What am I missing?
     
    Bai Shen
    Ranch Hand
    Posts: 323
    • Mark post as helpful
    • send pies
    • Quote
    • Report post to moderator
    Never mind. Turns out I had to install the Web Tools plug in for Eclipse.
     
    Peter Johnson
    author
    Bartender
    Posts: 5852
    7
    Android Eclipse IDE Ubuntu
    • Mark post as helpful
    • send pies
    • Quote
    • Report post to moderator
    How did you install Eclipse on Ubuntu? Did you go through the package manager? I recommend that you don't do that, instead download Eclipse from the Eclipse web site (get the "Eclipse IDE for Java EE Developers" package) and install that. Installation is easy - simply unpack the file; I put mine at /opt/eclipse. Then add it to the start menu and you are ready to go.
     
    Bai Shen
    Ranch Hand
    Posts: 323
    • Mark post as helpful
    • send pies
    • Quote
    • Report post to moderator
    Peter Johnson wrote:How did you install Eclipse on Ubuntu? Did you go through the package manager? I recommend that you don't do that, instead download Eclipse from the Eclipse web site (get the "Eclipse IDE for Java EE Developers" package) and install that. Installation is easy - simply unpack the file; I put mine at /opt/eclipse. Then add it to the start menu and you are ready to go.


    I did it through the package manager.

    I'm still having trouble getting it to see Tomcat, but I think I found a solution.
     
    Maneesh Godbole
    Saloon Keeper
    Posts: 11021
    12
    Android Eclipse IDE Google Web Toolkit Java Mac Ubuntu
    • Mark post as helpful
    • send pies
    • Quote
    • Report post to moderator
    Bai Shen wrote:
    I'm still having trouble getting it to see Tomcat, but I think I found a solution.

    Check out the Sysdeo Plugin Works even with the eclipse classic versions
     
    Bai Shen
    Ranch Hand
    Posts: 323
    • Mark post as helpful
    • send pies
    • Quote
    • Report post to moderator
    I went and downloaded the EE version of Eclipse and was able to get Tomcat working that way.
     
    • Post Reply
    • Bookmark Topic Watch Topic
    • New Topic