File APIs for Java Developers
Manipulate DOC, XLS, PPT, PDF and many others from your application.
http://aspose.com/file-tools
The moose likes GWT and the fly likes How to Upgrade GWT 2.0.4 to GWT 2.2.0 Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login


Win a copy of EJB 3 in Action this week in the EJB and other Java EE Technologies forum!
JavaRanch » Java Forums » Frameworks » GWT
Bookmark "How to Upgrade GWT 2.0.4 to GWT 2.2.0" Watch "How to Upgrade GWT 2.0.4 to GWT 2.2.0" New topic
Author

How to Upgrade GWT 2.0.4 to GWT 2.2.0

Mohit J Kumar
Greenhorn

Joined: Apr 08, 2010
Posts: 28

Hi all,
I am a beginner in GWT. I was using GWT 2.0.4 and have update it to GWT 2.2.0 recently and since the update it is not working. I am using ANT to build my project but it showing errors like hell.
Almost all the problems are in gwt-user.jar and other jars bundled with GWT.

Here is what I have done to update GWT :
1. Downloaded GWT-2.2.0 SDK
2. Replaced GWT-2.0.4 with GWT-2.2.0
3. Updated the path of GWT SDK accordingly in my ANT build.properties file.

There is no error in the compilation of my own code yet.All the errors it shows are in gwt-user.jar
and many others.
Do I need to update the other JARs OR is there something else.
Below is the snippet of the stacktrace.
Please explain in step by step fashion if possible.
Complete stack trace can be provided if necessary.

[java] [ERROR] Errors in 'jar:file:/C:/Programs/tools/gwt-2.2.0/gwt-user.jar!/com/google/gwt/emul/java/math/Logical.java'
[java] [ERROR] Line 51: that.sign cannot be resolved or is not a field
[java] [ERROR] Line 51: val.sign cannot be resolved or is not a field
[java] [ERROR] Line 54: BigInteger.MINUS_ONE cannot be resolved
[java] [ERROR] Line 57: BigInteger.MINUS_ONE cannot be resolved
[java] [ERROR] Line 61: val.sign cannot be resolved or is not a field
[java] [ERROR] Line 62: that.sign cannot be resolved or is not a field
[java] [ERROR] Line 68: that.sign cannot be resolved or is not a field
[java] [ERROR] Line 70: val.numberLength cannot be resolved or is not a field
[java] [ERROR] Line 70: that.numberLength cannot be resolved or is not a field
[java] [ERROR] Line 86: The method getFirstNonzeroDigit() is undefined for the type BigInteger
[java] [ERROR] Line 87: The method getFirstNonzeroDigit() is undefined for the type BigInteger
[java] [ERROR] Line 91: positive.numberLength cannot be resolved or is not a field
[java] [ERROR] Line 94: positive.numberLength cannot be resolved or is not a field
[java] [ERROR] Line 100: negative.digits cannot be resolved or is not a field
[java] [ERROR] Line 100: positive.digits cannot be resolved or is not a field
[java] [ERROR] Line 103: negative.numberLength cannot be resolved or is not a field
[java] [ERROR] Line 103: positive.numberLength cannot be resolved or is not a field
[java] [ERROR] Line 105: negative.digits cannot be resolved or is not a field
[java] [ERROR] Line 105: positive.digits cannot be resolved or is not a field
[java] [ERROR] Line 109: negative.numberLength cannot be resolved or is not a field
[java] [ERROR] Line 110: positive.numberLength cannot be resolved or is not a field
[java] [ERROR] Line 111: positive.digits cannot be resolved or is not a field
[java] [ERROR] Line 115: The constructor BigInteger(int, int, int[]) is undefined
[java] [ERROR] Line 116: The method cutOffLeadingZeroes() is undefined for the type BigInteger
[java] [ERROR] Line 129: The method getFirstNonzeroDigit() is undefined for the type BigInteger
[java] [ERROR] Line 130: The method getFirstNonzeroDigit() is undefined for the type BigInteger
[java] [ERROR] Line 133: shorter.numberLength cannot be resolved or is not a field
[java] [ERROR] Line 142: shorter.digits cannot be resolved or is not a field
[java] [ERROR] Line 142: longer.digits cannot be resolved or is not a field
[java] [ERROR] Line 144: shorter.digits cannot be resolved or is not a field
[java] [ERROR] Line 144: longer.digits cannot be resolved or is not a field
[java] [ERROR] Line 146: shorter.digits cannot be resolved or is not a field
[java] [ERROR] Line 146: longer.digits cannot be resolved or is not a field
[java] [ERROR] Line 149: shorter.numberLength cannot be resolved or is not a field
[java] [ERROR] Line 150: longer.digits cannot be resolved or is not a field
[java] [ERROR] Line 150: shorter.digits cannot be resolved or is not a field
[java] [ERROR] Line 156: longer.numberLength cannot be resolved or is not a field
[java] [ERROR] Line 156: longer.digits cannot be resolved or is not a field

"It's good to B in touch...So keep responding"
Scott Selikoff
Saloon Keeper

Joined: Oct 23, 2005
Posts: 3697
    
    5

First, check the release notes for 2.1.0 and 2.2.0. Also, 2.3.0 is now available.

One thing they have added is the requirement to include additional Jars in Ant scripts in more recent versions such as: gwt-dev-windows.jar, gwt-servlet.jar, gwt-servlet-deps.jar, validation-api-1.0.0.GA.jar, validation-api-1.0.0.GA-sources.jar, gwt-user.jar

Also, as I pointed out in a blog article GWT 2.2 breaks plug-ins compiled before GWT 2.2, so you need to upgrade all plugins as part of the GWT upgrade process.

As for your specific error, nothing sticks although upgrading can trigger a slew of build errors so I would review the suggestions above and see if any of them resolve your issues as they did mine. What version of the Java JVM are using by the way?


My Blog: Down Home Country Coding with Scott Selikoff
 
I agree. Here's the link: http://aspose.com/file-tools
 
subject: How to Upgrade GWT 2.0.4 to GWT 2.2.0
 
Similar Threads
Very frustrated with jboss 6 and seam.
Post upgradation problems
Some errors
Exception in thread "AWT-EventQueue-1"
HTTP Status 404