This week's book giveaway is in the Mac OS forum.
We're giving away four copies of a choice of "Take Control of Upgrading to Yosemite" or "Take Control of Automating Your Mac" and have Joe Kissell on-line!
See this thread for details.
The moose likes Tomcat and the fly likes Tomcat startup problems Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login


JavaRanch » Java Forums » Products » Tomcat
Bookmark "Tomcat startup problems" Watch "Tomcat startup problems" New topic
Author

Tomcat startup problems

Joe Harry
Ranch Hand

Joined: Sep 26, 2006
Posts: 9394
    
    2

Guys,

I have troubles getting Tomcat up and running. I have a Tomcat server configured in Eclipse and it configured to my projects document base. But when I start, I see the following error:



Where ad which specific jars that I should add and where?


SCJP 1.4, SCWCD 1.4 - Hints for you, Certified Scrum Master
Did a rm -R / to find out that I lost my entire Linux installation!
Joe Harry
Ranch Hand

Joined: Sep 26, 2006
Posts: 9394
    
    2

Tried all what I could, but still not able to get past this error. I actually imported my Maven project into eclipse and followed the normal way to configure a Tomcat server in eclipse. Why is this giving a class not found?
K. Gil
Ranch Hand

Joined: Apr 29, 2011
Posts: 75

here's the missing classes:
java.lang.ClassNotFoundException: org.springframework.web.util.Log4jConfigListener
java.lang.ClassNotFoundException: org.springframework.web.context.ContextLoaderListener
java.lang.ClassNotFoundException: org.springframework.web.context.request.RequestContextListener
java.lang.ClassNotFoundException: org.apache.struts2.tiles.StrutsTilesListener

spring framework and struts jar files are missign in tomcat/lib (or WEB-INF/lib)

http://mirrors.ibiblio.org/pub/mirrors/maven2/org/springframework/spring/
http://mirrors.ibiblio.org/pub/mirrors/maven2/org/apache/struts/struts2-tiles-plugin/

good luck!
UKi6.com - Java Hosting
 
GeeCON Prague 2014
 
subject: Tomcat startup problems