This week's book giveaway is in the OO, Patterns, UML and Refactoring forum.
We're giving away four copies of Refactoring for Software Design Smells: Managing Technical Debt and have Girish Suryanarayana, Ganesh Samarthyam & Tushar Sharma on-line!
See this thread for details.
The moose likes BEA/Weblogic and the fly likes Cant look up from one deployment to another. Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login

JavaRanch » Java Forums » Products » BEA/Weblogic
Bookmark "Cant look up from one deployment to another." Watch "Cant look up from one deployment to another." New topic

Cant look up from one deployment to another.

ray frid
Ranch Hand

Joined: Dec 23, 2010
Posts: 79

I am using weblogic 11g, Ejb3.0

Problem is that I cant see the jndi tree in the weblogic console. And more over I cant do look up from one deployment ear to another

I am running the weblogic locally from MyEclipse.

My JNDI tree fro some reason via the console doesnt show my EJBS.

Now this is how my stateless been which I am trying to look up into looks like: (I tried variouse things)

@Local ({SyncOperatorsBeanLocal.class})
@Remote ({SyncOperatorsBeanRemote.class})
@Stateless(mappedName = "SyncOperatorsBean")
public class SyncOperatorsBean implements SyncOperatorsBeanLocal,SyncOperatorsBeanRemote
public void executeSyncOperation()

And this is the Joline I am executing from my job class in order to run the SyncOperatorsBean.executeSyncOperation

SyncOperatorsBeanRemote SyncOperatorsBean = (SyncOperatorsBeanRemote) context


Now that’s the exception:

javax.naming.NameNotFoundException: While trying to lookup 'SyncOperatorsBean#com.mirs.sbngenerate.beans.SyncOperatorsBeanRemote' didn't find subcontext 'SyncOperatorsBean#com'. Resolved ''; remaining name 'SyncOperatorsBean#com/mirs/sbngenerate/beans/SyncOperatorsBeanRemote'
at weblogic.jndi.internal.BasicNamingNode.newNameNotFoundException(
at weblogic.jndi.internal.BasicNamingNode.lookupHere(
at weblogic.jndi.internal.ServerNamingNode.lookupHere(
at weblogic.jndi.internal.BasicNamingNode.lookup(
at weblogic.jndi.internal.WLEventContextImpl.lookup(
at weblogic.jndi.internal.WLContextImpl.lookup(
at com.mirs.ecms.timer.StartSyncJob.execute(
at org.quartz.simpl.SimpleThreadPool$


ray frid
Ranch Hand

Joined: Dec 23, 2010
Posts: 79
I have added @JNDIName("ejb/SyncOperatorsBean") to the bean SyncOperatorsBean. and it solved the JNDI TREE prob. I can see it there. but I still can do look up.
same error.

any idea?
I’ve looked at a lot of different solutions, and in my humble opinion Aspose is the way to go. Here’s the link:
subject: Cant look up from one deployment to another.
It's not a secret anymore!