This week's book giveaway is in the OCMJEA forum.
We're giving away four copies of OCM Java EE 6 Enterprise Architect Exam Guide and have Paul Allen & Joseph Bambara on-line!
See this thread for details.
The moose likes Ranch Office and the fly likes Old JavaRanch Forums Links Broken Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login


Win a copy of OCM Java EE 6 Enterprise Architect Exam Guide this week in the OCMJEA forum!
JavaRanch » Java Forums » This Site » Ranch Office
Bookmark "Old JavaRanch Forums Links Broken" Watch "Old JavaRanch Forums Links Broken" New topic
Author

Old JavaRanch Forums Links Broken

Bruce Coleman
Greenhorn

Joined: Mar 28, 2002
Posts: 9
(I searched on the topic of broken forums links but didn't find the answer I was after.)

With the new Saloon and domain, some links to old forums posts aren't working. For example, many (or all) of the links from Junilu Lacar's OOCalculator threads listing currently just lead to an Apache Tomcat error page, whining about "The requested resource (/cgi-bin/ubb/ultimatebb.cgi) is not available."

I can Google around and find most of the old pages I'm looking for this time, but that's not the point.

Is this a known issue? Is this issue likely to be resolved? Is there a fancy URI fiddling trick to create the new URI from the old URI?

Gracias.
Maneesh Godbole
Saloon Keeper

Joined: Jul 26, 2007
Posts: 10269
    
    8

Works for me. Is it possible for you to try on a different machine?


[Thumbnail for screenshot.png]



[How to ask questions] [Donate a pint, save a life!] [Onff-turn it on!]
Bruce Coleman
Greenhorn

Joined: Mar 28, 2002
Posts: 9
To clarify, does it work for you to follow the first link I posted to the OOCalculator listing, and then to follow one of the links from that page to another thread of the OOCalculator?

The screen shot you posted is just of the first page. Getting to the first page isn't the problem. The problem is following the links from that page.

(I'll try on another machine, but...)

Update: I tried from three machines (Win 7, Win XP, Ubuntu) with two different browsers (Firefox 4, Chrome), and the same thing happened from all of them.
Maneesh Godbole
Saloon Keeper

Joined: Jul 26, 2007
Posts: 10269
    
    8

Ah! You meant the links from inside the topic.
Yes. Doesn't work for me too. Thanks for bringing this up.
Ernest Friedman-Hill
author and iconoclast
Marshal

Joined: Jul 08, 2003
Posts: 24183
    
  34

Those links are just bad links, flat out. The text of the link you've shown above is:

http://www.javaranch.com/cgi-bin/ubb/ultimatebb.cgi?ubb=get_topic&f=9&t=001079&p=2

I am surprised that this would ever have worked. It's a little bit before my time, though, so perhaps things were different back then. Anyway, the correct link is

http://www.coderanch.com/t/97611/patterns/OO-Calculator-Tutorial

And indeed, that works fine. I fixed the first dozen or so links in that thread, but sorry, I don't have the patience to do all of them right now.


[Jess in Action][AskingGoodQuestions]
Bruce Coleman
Greenhorn

Joined: Mar 28, 2002
Posts: 9
Ah. The fix is to replace www with saloon. Thank you.

Google Search for "http://www.javaranch.com/cgi-bin/ubb/ultimatebb.cgi"

http://www.google.com/search?btnG=1&pws=0&q=%22http%3A%2F%2Fwww.javaranch.com%2Fcgi-bin%2Fubb%2Fultimatebb.cgi%22

About 5,510 results

Google Search for site:coderanch.com "http://www.javaranch.com/cgi-bin/ubb/ultimatebb.cgi"

http://www.google.com/search?btnG=1&pws=0&q=site:coderanch.com+%22http%3A%2F%2Fwww.javaranch.com%2Fcgi-bin%2Fubb%2Fultimatebb.cgi%22

About 2,720 results

Maybe a solution is in order.
 
I agree. Here's the link: http://aspose.com/file-tools
 
subject: Old JavaRanch Forums Links Broken