Win a copy of Mesos in Action this week in the Cloud/Virtualizaton forum!
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic

[OC4J] Deploy webapp was good, but login.jsp not accessible

 
Renato Bobbio Calogero
Greenhorn
Posts: 18
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Dear forum users, I run into a problem while deploying my working webapp in a OC4J remote instance on a remote machine.

I have installed JDeveloper 10.1.2 , and a local instance of OC4J, in which I can deploy my webapp and it works perfectly fine.
Now, when I try to deploy my .ear archive throught the web console of Oracle Enterprise Manager 10g it is deployed fine,

...BUT...

when I try to access to my application at the address offered by oc4j on the remote machine

http://orabpel.xxx.xxx.xxx:7777/MyApp

I got prompted with a popup ( the classical IE or Firefox download popup ) which force me to download
an octet/application stream, and my login.jsp does not show up!

I am wondering why this happens. Lurking on the web I found this topic

http://jira.icefaces.org/browse/ICE-1793;jsessionid=7ADFCCADE6D27465F3CBFB3C496B6772?page=com.atlassian.jira.plugin.system.issuetabpanels%3Aall-tabpanel

which say that I might have misdeclared the content type of my Login.jsp page ( which is mapped as Welcome File in my web.xml )

but I did put the correct jsp content type declaration as follows

<%@ page contentType="text/html"%>

Can anybody help a poor total noob please ? I am totally stuck, I don't even get an exception and I can't even google some more information!

Thanks in advance,

Renato
 
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic