Get your CodeRanch badge!*
The moose likes Object Relational Mapping and the fly likes ORA-00942: table or view does not exist Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login


Win a copy of Java 8 in Action this week in the Java 8 forum!
JavaRanch » Java Forums » Databases » Object Relational Mapping
Bookmark "ORA-00942: table or view does not exist" Watch "ORA-00942: table or view does not exist" New topic
Author

ORA-00942: table or view does not exist

Aruna Ponaka
Greenhorn

Joined: Dec 08, 2009
Posts: 8
i have enabled "show_sql" to true and can see the following hibernate query

Hibernate: insert into defaultschema.rca_param (param_val_t, param_remk_t, defunct_f, param_t) values (?, ?, ?, ?)

but i get the SEVERE: ORA-00942: table or view does not exist.

The database has the rca_param table and the columns.

When i run the same sql removing the defaultschema from the query, i.e.

insert into rca_param (param_val_t, param_remk_t, defunct_f, param_t) values ('T','T',"Y','Y');

the query executes in TOAD, but when i run the code, i get the table or view not found exception.

Avi Abrami
Ranch Hand

Joined: Oct 11, 2000
Posts: 1121

Aruna,
I am aware of only two causes for the Oracle error code ORA-00942
  • The table (or view) really doesn't exist
  • The database user does not have permission to access (or modify) the table

  • Since you claim to be able to modify the table via TOAD but not via Hibernate, my guess is that you are using different database users in TOAD and Hibernate.
    Also, when accessing a table in Oracle, you only really need to prefix the table name with its schema name if you are accessing it from a different schema.

    Hope this helps you.

    Good Luck,
    Avi.
     
    With a little knowledge, a cast iron skillet is non-stick and lasts a lifetime.
     
    subject: ORA-00942: table or view does not exist
     
    Similar Threads
    weird executeUpdate error?
    java.sql.SQLException: ORA-00942
    javax.servlet.ServletException:[Oracle][ODBC] [Ora]ORA-00942: table or view does not exist
    Exception when having different class and table name
    no. of connection